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Overview

This manual is a guideline to using the two Roland CNC milling machines.  This is only a guideline and is not
the one-and-only way to setup and run the machines but it is a good way.  If you’re new to using the machines I
would highly recommend doing it this way until you are familiar with both the software and hardware.  Once
familiar with the setup feel free to make changes to the procedure to better fit your exact needs.

Safety

You must ALWAYS WEAR YOUR SAFETY GLASSES while around the CNC mills.  Even if the spindle is
not running a carbide tool that breaks due to a collision with the vise or table is just as dangerous as chips off a
running cutter.

If you are going to be around the mills an extended amount of time while they are running then you might want
to consider hearing protection although this is not required.

These are automated machines and may move unexpectedly.  Keep your body parts out of pinch points,
especially behind the table and between the table and cutter.

The tools themselves are very sharp and should be given the same respect that you would give a scalpel or sharp
knife.

Preparing Parts for the CNC Mills

The first thing after designing your part in a 3-D modeling package like Mechanical Desktop (Matt’s Choice) or
Pro-Engineer (Dan Boy’s Choice) is to get the part ready to be machined.  You need to hold the part in the
mill’s vise and yet allow the tool to cut around the entire part.  This is best accomplished by mounting the part
in a frame with sprues to connect the part to a frame.  You should end up with a finished part that is held in a
frame like plastic model airplane parts come in the box.  See the example pictures included.

Note:  Tip when mounting part in frame:
1. The sprues should be taller then they are wide, but not the full thickness of the part.
2. The part should have 1.5 times the cutter diameter space between the part and frame.
3. You should have at least one sprue per side.
4. The frame should be a nominal thickness that is the same as your stock ( i.e 1/8 inch ¼ inch, 3/8 inch.)
5. The frame should also be relatively thin.  You don’t want to spend too much time to machining the frame.

0.01 inches is a pretty good frame thickness.

Once the part is laid out in its frame the part needs to be exported in STL format for transferred to the computer
that is connected to the CNC Mills.
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Exporting Mechanical Desktop parts as STL files

With Mechanical Desktop you will need to make a copy of your part.  Make sure the part is in the positive
octant (all coordinates of the entire part must be positive.).  Then use the <explode> command to explode the
part changing from a mechanical desktop part into a true 3-D solid.  Set the system variable {facetres} to
between 2-4.  This affects the density of the STL-mesh.  Switch to the world coordinates and orient the part so
that the tool’s rotation is about the z axis.  Once oriented correctly use the <stlout> command. Chose the solid,
say NO to the “create binary file?” and give the file a name.

Note:  If you have more curves, set the {facetres} parameter higher.  If you have a part with very large or no
curves you can leave this number smaller and the STL file will be much smaller.

If you only need to machine from one side to capture the desired features then you are done.  If you need to
machine from both sides then you will need to rotate the part 90 degrees positive about the world Z axis and
output a second STL file.  A good naming scheme here is to give the first side a filenameA.stl and then
filenameB.stl.  Once these files are created send them to the computer connected to the CNC mills.

Exporting ProE drawings as STL files

1. Before beginning the drawing, create datum planes for the part.  You can do this on the window by:
Feature>Create>Datum>Plane>Default.  This should be done before starting any drawing.

2. When the drawing is complete, use File>Export>Model>STL to create the STL file.
3. In the format window that pops up, be sure to select ASCII.
4. Adjust the chord length to produce a fairly smooth shape; smaller chords produce smoother shapes and

bigger files.
5. Click Apply to see if the surface looks acceptable.
6. Click OK to export the file.  It will default to the Bin directory.

This process will work for assembly files as well as parts.  It is suggested that you design the part(s) and sprue
as separate parts, assemble them, and convert the assembly to a STL file.

Loading Material into the CNC Mills

Before setting up the computer attached to the CNC mills you will
need to load the mill with a blank piece of material.  This blank should
be at least ½ inch bigger on each side then the frame around your part.
This will leave a ¼ inch extra material around your entire part.  This
should be stiff enough in most cases to keep the frame flat when you
machine the second side.  The blank should also be the same thickness
as the frame in the drawn part.

Note:  If the blank is slightly thicker then the actual nominal
dimension this can be adjusted for before the part is machined.
Measure the blank before loading and remember the difference
between the measure blank thickness and the nominal frame thickness.

Now load the blank in the machine.  Turn the mill on with the large
square yellow button on the front of the mill controller.  Allow the
machine to run its self-check and calibration after the table has
finished moving you can put the blank in the vise of the mill.  On the
larger machine, the PNC-3100 be sure to use the parallel blocks to put
the part as near top of the vise as possible.  In either case you need to
be sure that the blank is pressed firmly down into to the vise to ensure
that the part is flat.  For the setup process you will need put a 1/8-inch
mill in the collet.

PNC-2500  the small CNC mill

PNC-3100 Larger CNC Mill
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Note:  The collet on the PNC 3100 requires only one wrench to hold the spindle and is then tightened by hand.
The PNC 2500 used two wrenches-one on the spindle and one on the collet.  Be sure the collet is tight but do
not over tighten.  You should not have to herniate yourself doing this.  Be sure that the spindle switch on the
front of the machine is off when loading a tool.  This ensures that the
spindle cannot turn on.

Uses the pendant to move the tool to the lower left corner of the
blank.  Use the X and Y button on the pendant for coarse movement
and then the jog button and jog wheel to make fine movements.  To
use the jog wheel select the axis you want to move with the jog button
and then turn the wheel the appropriate direction.  Using a ruler move
the tool 3/16 in from both left and front edge of the blank.  This gives
the ¼ inch to the center of the tool.  Place the end of the ruler against
the tool so that the entire end of the ruler is in contact with both flutes
and tool shaft.  Then you can measure 3/16-inch on the edge of the
blank.  Once you have the tool 3/16 from both the left and front side
you will need to set this as (0,0,0) in the machine coordinates. To do this, hold down the [Enter] button and then
press [Home] button releasing them together.  The X and Y values of the pendent should go to zero.  Will get to
the Z-axis shortly.

Note:  The PNC 3100 will remember this setting if you have to cycle the power-the PNC 2500 will not.

Next you will need to mark this point on the blank for later reference when aligning the part for machining the
other side.  To do this make sure the blank and cutter is clear of rulers, finger, and any other foreign object you
do not want a hole in and drill a 1/8-inch hole through the part with the 1/8 inch end mill.  To do this, turn the
spindle on by holding the spindle test [ON/OFF] button until the spindle starts.

Note: If the spindle does not turn on make sure the spindle switch on
the front of the mill head is in the on position.  You hopefully had
turned this off when you put the tool in the spindle.  The knob on the
front of the controller box is the manual spindle speed control.  Be
sure spin the tool fast enough for the material you are cutting.  For
most materials as fast a possible will work fine, but some materials
will melt onto the tool and brake it.  Plexiglass is a prime example of a
material that must be machined slowly with a lower RPM cutter.

Now that the spindle is running press the [JOG] button until the Z-axis
LED is light up.  Double check that you are still at X = 0 and Y = 0.
Use the JOG knob to slowly lower the head of the mill to drilling a
hole through the blank.  Make sure that the blocks are moved so you
do not hit them when drilling through.  Do not to drill into the vise
below.  Once drilled through the blank withdraw the tool and turn the
spindle off by pressing the spindle test [ON/OFF] button.

Next choose the tool that will be used to cut the part.  Remember the
larger the tool the fast the part will machine.  The smaller the tool the
finer detail that you will be able to capture.  Put the chosen tool in the
mill, move over to the left about 1/8 (about 300-400 units on the
pendant) and do “touch test” with a spinning tool to find the top of the
blank.  To do this start the spindle with the spindle test [ON/OFF] and

use the Z JOG to move down very slowly until you just see the first very small chips come off the blank.  You
will have to look very carefully to see this (extra light here helps).  Be sure you are wearing you safety glasses.
You should be able to hold 0 to –0.002 thousands accuracy with only a little practice.  Once you have the tool at
the surface of the blank set this as Z-Zero by pressing and holding [Enter] and then press [Z0] and release both.

Pendant for CNC mill

Spindle Switches: PNC 2500 top,
PNC 3100 bottom
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If you mess up just move to a different part of the blank out on the frame and try again.  You have now set up
the CNC machine for machining.

Note:  The units displayed on the pendant are hundredths of a millimeter.

Setup Computer to Send Tool Paths to CNC Mill

Now you will need to run the software to actually communicate with the
CNC mills.  The program is Modela 3D Player.  It should be in Start-
>Programs->Modela Apps group->mdx3p.  This program will take your
STL file and calculate the need tool paths to cut your part.

After running the app use the file->open command and open the
filenameA.stl file.  This should open and display you STL part file.

First select the CNC milling
machine that you have just set up in
the previous section.  This is in the
File->Print Setup  dialog box.  Your
choices should be Roland CAMM-3
PNC-2700(this is the driver for the
PNC-2500), Roland CAMM-3
PNC-3100 and maybe one or two
actual printers.  Be sure not to pick a
printer but pick the machine that
holds your part blank. Press OK.

Next go to Option->Layout dialog box.  Set the LowerLeft
X, LowerLeft Y and Margin to Zero.  This will move the
point (0,0,0) to the point you setup on the mill.  By setting
the margin to zero the cutter will not be allowed to leave the
box defined by the frame around your part thus keeping the
frame attached to excess material on the blank.  Click OK.

Be sure that there is not a check
next to Abstract on the Option-
>Abstact menu.  If there is, simply
click on Option->Abstact  to
remove it.

On the Option->Path Direction  dialog box and set draft to Contouring .  If
you do not expect to need fine passes then be sure to check the Contoured
check box.  This will make the cutter cut an exact perimeter around you
part after each material removal pass.  If you are going to do fine passes
then you do not need to waste time doing this.  The roughness left by the
material removal passes will be cleaned up in the fine passes.  On the fine
side of the dialog box choose X Scan Line, Y Scan Line, or X + Y Scan
Line passes depending on you needs. Click OK

Note:  For fine pass directions use fine passes the are perpendicular to the axis of the prominent curves that are
present in the part.  High precision should only be used for very small parts.  This will not slow down actual
machining time but will greatly increase the time to calculate the tool paths.

Now you will need to use the [NEXT] button at the bottom of the screed to step through next several screens.
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Click [NEXT] once and you will come to the direction screen.  Chose what orientation you would like to
machine from.  In most cases you should machine filenameA.stl from the top and filenameB.stl from the
bottom.

Click [NEXT] once and you will be at the Size screen.  Pick a known dimension of one side of the part and
enter this into the appropriate field by clicking on the field.  It will scale the other dimensions correctly.

Click [NEXT] once and you will be at the depth screen.  On this screen set the maximum depth the tool will be
allowed to cut.  Note: don’t cut deeper then needed to capture the detail this will only waste time.  Also make
sure not to hit the shaft of the tool on the frame or part.



The Roland CNC Mill Manual

This Is Page6

Note:  In general these are safe max depth settings
1/32 inch end mill will cut 0.1 inch deep
1/16 inch end mill will cut 0.2 inch deep
3/32 inch end mill will cut 0.25 inch deep
1/8 inch end mill will cut 0.5 inch deep

Click [NEXT] once and you will be at the tool page.  Click the tool diameter field and enter the diameter of the
tool.  You can enter either decimal or fraction dimensions.  Then choose whether you are using square end or
ball-end end-mill.  Here you will also choose Draft or Fine passes.  Be sure to do Draft passes before Fine
passes.  Select an appropriate material from the list of materials.

Note: If you need you can create your own material in the option menu.  You will need to know the appropriate
tool feed speeds for the material and tool diameter.

Note:  For most things a square-end mill works great.  If most of the surface are flat then this is the best choice.
If you have many concave surface features then a ball-end mill would be the better choice to achieve good
surface finish.

Click [NEXT] once and you will be at the review screen where you started.  At this point you NEED TO
DOUBLE-CHECK ALL SETTINGS.  When you are happy with the setting click the [Tool Path] button and it
will calculate the tool paths and display them on your part.  Inspect this carefully and make sure it is capturing
all the details you expected.
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If you need to compensate for a material blank that is
slightly thicker then the nominal dimension, now is the
time to do this.  Go to the Options->Layout dialog box and
in the lower left corner enter the difference between the
frame thickness and the actual thickness of the blank in
thousands of an inch in the surfacing depth box.  Leave
the automatic box checked and when the mill is clear of all
fury defenseless critters click the [START] button that in
in the dialog box not the one at the bottom of the screen.
The machine will remove the excess thickness and reset
your Z-zero.  Click OK and continue on.

Make sure you and your friends (the ones you still like)
are clear of the machine and click the [START] button.

The program will down load the data to the CNC controller.  The Mill head should rise to the top of its stroke
shortly after sending the data, and then 20-30 second later the spindle should start and begin cutting.  If you are
using the PNC 2500 then be sure that the spindle speed is set manually on the front of the controller.  The PNC
3100 spindle speed should be set already in the software.  Be sure to stay with the machine while it completes
its first two passes.  Watch to make sure it will not hit the vise and that it is doing what you expected.  On the
second pass watch the depth to make sure this is not too deep for the material you are cutting.  If the machine is
laboring shut if off and chose more conservative parameters and try again.  If at anytime you fear for the
machine’s or your own safety punch the [ON/OFF] button.  This will shut down the machine and save you and
the machine from injury, but you will have to re-setup the mill to try again.

Once the draft passes are sent to the mill you can send the fine passes.  Click on the [Draft] button and this will
take you to the tool screen where you can select [Fine].  Use the [Back] button and you will come back to the
review screen.  Click on [Tool Path] button, inspect and then press [Start].  You can send both the draft and fine
passes immediately to the CNC controller the computer will buffer as needed.  You can also then send data to
the other machine by selecting that machine in the printer setup dialog box.

The second side

To machine the other side you will need to flip the part over in the vise so that the reference hole drilled earlier
is still in the lower left corner.  Put a tool in backwards so that square smooth end of the mill is sticking out of
the spindle.  Put the part on the tool shaft and use the pendant to VERY CAREFULLY lower the part into the
vice.  Move the part down onto the blocks and center against the stationary jaw of the vise.  This is somewhat
difficult to do and will take practice.  Be careful and do most of you movement with the JOG wheel not the
direction button on the pendent.  Once you are against the stationary jaw of the vise tighten the vise down on the
partial part.  Zero the X and Y Coordinates by holding [Enter] then press [Home] release both. This is a good
approximate Zero.  The X direction will be dead on but the Y direction could be off by a little bit due to over or
under loading the blank as you move against the stationary jaw of the vise.  Use the Y JOG wheel and the Z up
and down buttons to move the tool in and out of the hole adjusting the Y coordinate until the tool goes cleanly
and easily in and out of the hole with no perceivable flexion of the tool.  This should put you with in +/- 0.003
inch of the hole’s center.  Re-Zero your X and Y coordinate by holding [Enter] then press [Home] release both.
Put your tool of choice in the machine and do a Z surface find as done earlier.  The machine is now ready for
the second side.

The computer setup is pretty much the same except load the filenameB.stl file and be sure to select machine
from bottom on the direction page.  Every thing else should be the same.


