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1.  Pixform Pro Getting Started 
 
System Requirements 
See the page “System Requirements” in the chapter “4. Basics.” 
 
Installing Pixform Pro software 
See the page “Installation and Licensing” in the chapter “4. Basics.” 
 
Starting Pixform Pro 
Double-click the Pixform Pro icon on the desktop or click the Start button on the 
Windows taskbar and then click Pixform Pro in Programs. 
 
Using Pixform Pro’s example files 
The example files are placed in the installation directory\Sample folder. The default 
installation directory is C:\Program Files\Roland Pixform Pro. 
 
Using tutorial sample files 
The full manual and sample files are placed in the installation directory\Tutorial 
folder. All the sample files are located in the corresponding workbench directories. 

1. Create a new folder on your system, and copy the sample files into the 
local folder. 

NOTE: Since some of the sample files are used with more than one example, 
do not save changes to these files unless instructed to do so. 

2. Go through this manual from beginning to end, opening the proper 
sample for each function, or use the Table of Contents to locate topics 
of special interest to you. 

 



2. Overview 
Pixform Pro consists of four workbenches:  Scan, Polygon, Curve, Surface. 
 

Common (across all workbenches): 
• Customizable GUI (e.g. menu, toolbar, shortcut key, color map) 
• Unlimited undo operation 
• Program crash handling (backup file and bug report generation) 
• Working view volume management 
• Rotation center changing and view point saving 
• Various selection tools 
• Automatic symmetrical plane finding and mirror selection system 
• Layer management 
• Various reference geometries (e.g. point, vector, plane, circle, sphere, 

cylinder, cone, box, torus, coordinate) 
• Dimension measuring 
• Transformation (Translation, Rotation, Scaling) 
• Landmark based automatic measuring 
• Point cloud shading 
• Complete texture information support 
• 3D polygon data compression (ICF file format) 
• Export color 3D content for Web-based applications 
• Magellan/SpaceMouse® interface 
• Open architecture: Windows® OLE automation-based API 
• Comprehensive command interpreter 

 
Scan Workbench : 

• Reduce scan noise caused by scanners 
• Point cloud sampling (random, uniform or by curvature) 
• Intelligent point cloud smoothing 
• Automatic creation of polygonal models from point cloud data 
• Align/register point/polygon data in two different coordinate frames 
• Automatic registration for rotary table scans 
• Merge multiple polygonal models with high accuracy 
• Point cloud merging and polygon combining 
• Texture based point dithering 
• Volume based triangulation and merging operation 

 
Polygon Workbench : 

• Automatic detection and cleaning of bad polygon meshes 
• Quality enhancement smoothing and real-time smoothing 
• Curvature-based decimation and large data decimation 
• Automatic global re-meshing for dramatic polygon quality enhancement 
• Intelligent subdivision 
• Curvature-based hole filling 
• Re-fitting polygon to original points, polygon or surfaces 
• Automatic boundary edge shrinking (at variable depths) 
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• Sharp edge reconstruction using curves 
• Re-fitting to primitive surfaces (Plane, Cylinder, Cone & Sphere) 
• Virtual sculpting and freeform deformation 
• Template based polygon refitting 
• Medial axis transformation 
• Polygon morphing 
• Trim, weld, split, offset, divide, mirror, extend, swap, flip, etc. 
• Verification tools (environment mapping, face angle plot, contour lines, 

etc.) 
• Shelling and thickening polygon 
• Boolean operations (union, intersection, difference) 
• Align polygon models in user defined work volume 
• Interference checking 
• Overhang region searching 
• Real-time collision detection and restriction 
• Engrave & emboss any 2D image or text onto a 3D model 
• Volume based hole filling and polygon offset 

 
Curve Workbench : 

• Automatic feature recognition and curve creation 
• Automatic global trimming 
• Automatic loop finding 
• Curve templates for similar objects 
• Various curve generation tools (interpolate, poly-line, rectangle, circle, 

ellipse, grid, cross-section, etc.) 
• Smooth boundary curve generation with rugged boundary edges 
• Fitting curves to points 
• Curve mirroring 
• Automatic curve generation on sharp edges 
• Various curve editing tools (trim, merge, smooth, offset, extend, rebuild, 

match, etc.) 
• Curve to points conversion 
• Curve deformation 
• Deviation error checking and curvature/torsion plot 
• Various curve viewing tools 

 
Surface Workbench : 

• Automatic NURBS surface generation from polygon models 
• High accuracy polygon-to-trimmed/untrimmed NURBS surface conversion 
• Point cloud to surface conversion 
• Surface mirroring by plane 
• Extensive surface editing tools (trim, untrim, divide, smooth, rebuild, 

tessellation, sew, join) 
• G0/G1/C1 continuity matching with multiple-adjacent surfaces 
• Interactive accuracy and curvature verification 
• Displacement map creation and export 
• Seamless integration with other CAD systems 
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• Automatic IGES surface healing 
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3. Work Process 
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Work Process: Surfacing 
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4.  Basics 
System Requirements 
 
Operating System: 
 

- Any Pentium-based or AMD Athlon-based PC running Windows 2000, Me, 
XP or NT 4.0(SP6 or higher). 

 
 
Memory and Disk Space: 

 
Memory: 
- Minimum 512 MB is required (1GB or more is recommended) 
- RAM requirements vary depending on the size of the model being worked on.  
- A simple estimate is to occupy 1 MB for every 10,000 triangles in the model. 
- In general, a physical memory for data handling needs two times of current 
occupied memory. (e.g.) Five million triangles need 500MB RAM for 
occupation and 1GB RAM for operation. Ten million points need 1GB RAM for 
loading and sampling. 
 
Disk Space: 
- 300 MB for program installation and more than 500MB free disk space is 

required for temporary file cache. 
- An additional 400 MB for training sample files 

 
Graphics Card: 

 
1280X1024 resolution, 32-bit color or above, OpenGL 1.2 or higher 
Recommended hardware OpenGL acceleration feature are listed below: 
 
- NVIDIA Quadro/GeForce compatible chipsets 
- 3DLabs Oxygen GVX Series 
- ATI FireGL compatible chipsets 
- 3DLabs Wildcat Series 
 
Note: Pixform Pro may not work properly with an old graphic board. You need 
to download the latest graphic driver from the website acquainted by your 
provider. 



 

 
 

4-2 

Installation and Licensing 
 

1. Connect a hard-lock (dongle) to a parallel port (printer port). 
2. Insert the Pixform Pro software CD into the CD-ROM drive. 
3. Within a few seconds, the installation program should appear automatically. If 

the autorun installation does not start automatically, browse the CD-ROM 
directory and then double-click on the autorun.exe file to start the installation 
program. 

4. Follow the instructions provided by the installation program. 
5. Run the application. 
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File I/O Specifications 
 

Extension Application Import Export Remark 
mdl (open) (save) Pixform Pro’s own binary format 
icf 

Pixform Pro 
X O INUS Compression Format 

pix (ver.3) Roland PICZA O X point / polygon, inch 
rdl Pixform O X point / polygon / surface 
asc ASCII points X O point 
wrl VRML 1.0/97 X O point / polygon 
dxf AutoCAD X O point / polygon 
stl Rapid Prototyping X O point / polygon (ASCII or Binary) 

igs / iges IGES  X O curve / surface 
3dm Rhino 3.0 X O curve / surface 

 
NOTE:  

- MDL format can also be opened and imported. 
- ASCII points file with three numbers on a line are a set of XYZ coordinates. 
 

   ●Importing Dr.PICZA Files  
  PIX format can be imported. 

 - Dr.PICZA versions 1 through 2 
   Not available. 
 - Dr.PICZA3 version 3 
   Use the [Save as...] command to save a file. 
 - Dr.PICZA3 version 4 
   Use the [Export] command to save a file. 
   The Dr.PICZA project format files (with the file extension .pij) cannot 
  be imported.  



 

 
 

4-4 

GUI 
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Mouse Control 
 
 
 

 
 
 
 
 
 

MIDDLE Button 
SCROLL: Zoom 
CLICK: Pause or Done 

LEFT Button 
Rotate 
+SHIFT: Zoom 
+CTRL: Pan 
Select 
+CTRL: Deselect 

RIGHT Button 
Pop-Up menu 
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Command Console 
 

The command console consists of the command prompt and a scrollable 
command output window. By default the command console is below the project tree 
and working window. A user can move the console window to other position.  

Most Pixform Pro commands can be run by typing the name or its abbreviation 
into the command prompt. For the user convenience, if a user types buttons 
continuously without pause, the mouse cursor automatically moves to the command 
prompt. 

A user can browse through a list of commands, and each command is 
accompanied by help information or balloon help. 

While you are typing a command, Esc key clears the command prompt. If no 
command is active in the menu, you cannot run it in the command prompt either. 

 
Basic Command: 

1. help - shows the usage of any command 
 (command) help  decimate ……show the usage of Decimate command 

2. list - shows the list of commands 
 (command) list  sel* ……show all commands beginning by “sel” 
        (command) list  /h sel* ……show all command beginning by “sel” with help 
3. dump - The text contents of command console are copied into the Windows 

Clipboard or notepad 
 (command) dump /notepad ……copy all contents to a notepad 

4. clear or cls – clear all the text contents of output window 
5. echo – display comment in the output window 

 (command) echo “Tips: decimate function reduces data size.” 
 

Alias & Bind: 
You can define your own command alias from the existing command. Command 

aliases are custom commands you can define to run Pixform Pro commands. You 
can type command aliases just like normal commands. You can use them to create 
abbreviations for often used commands.  

Also you can bind a series of commands to an alias. The aliases and bind 
commands are automatically saved to the console.ini file under the Pixform Pro 
home directory. When the application is launched, all the aliases and bind 
commands are automatically loaded from the file. To remove all user-defined 
commands, just delete the console.ini file from the directory. 

Note that an alias must consist of two or more characters in order to distinguish 
shortcut keys. 

 (command) alias +remg RemeshGlobal ……add “remg” to alias 
table(console.ini) 

       (command) remg ……run Remesh > Global command 
       (command) alias -remg ……delete “remg” from alias table 
 (command) bind +desm “selsh *” “decimate 50%” “smooth 1 2” 

 ……assign decimate and smooth commands to “desm” 
           (command) desm ……select all shells and then decimate and smooth them 

 (command) bind -desm ……delete “desm” from bind table (console.ini) 
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Environment Setting: 
It is possible to customize the environment of command prompt and console 

window as shown below.  

 
You can easily change it with option menus by clicking the RMB on the console 

output window. 

 
The Copy dumps the text contents of output window to the Windows Clipboard. 
The Key Stroke Sensitivity sets an interval of key stroke so that the mouse 

cursor automatically moves to the command prompt. Set the parameter 
“StrokeThreshold” to an interger between 1 to 1000 (unit: msec). It is usually 
recommended 150 ~ 200 msec. 

 (command) set strokethreshold 200 
The Enable Font Shadow sets the font shadow of text in the command prompt 

and output window to ON/OFF. 
The Font sets the font style of text in the command prompt and output window. 
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(command) set consolefont /setup 
You can also customize the color of command console with the Colors options or 

the “set” command following by the “/setup” parameter. Or, just select one of pre-
defined color environments, Theme. 

The Command & Prompt sets the color of commands in the command prompt 
and output window. 

The Comment sets the color of comment text in the output window. 
The Result sets the color of result message in the output window. 
The Error sets the color of error message in the output window. 
The Prompt Background sets the background color of command prompt. 
The Output Background sets the background color of output window. 

(command) set consolecoloroutput /setup 
set consolecoloroutput 182 245 162 255(no gradient) 

The Output Gradient sets the gradient color of output window. The first selected 
color is for the gradient of left side and the second one is for right side. 

The Output Selection sets the color of selected line in the output window. 
The Font Shadow sets the shadow color of text in the command prompt and 

output window. 
The customized settings are saved to the console.cfg file under the Pixform Pro 

home directory. When the application is launched, all the option values are 
automatically loaded from the file. To remove all user-defined options, just delete the 
console.cfg file from the directory. 
 
Parameter Type: 

All parameters in the dialog box of each function can be used in the command 
prompt. Each parameter is one of types with integer, real number, Boolean 
(true/false), string or special option. A command without any parameters might be 
executed by default values or the latest used ones. 

 (command)  open test.mdl 
 (command)  selsh scan1 scan2 

(command)  smooth 1 3 0.2 0.1 y n y n y 
 
Please see the on-line help for all command list and detail parameters. 
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Right Mouse Button Menu 
 
In addition to the menu bar, there are menus that appear when you click the right 
mouse button (RMB).  
 
On Toolbar: 

You can show or hide toolbars as selecting them after 
clicking RMB on menu bar or toolbars (as shown right). 
Also, you can customize GUI and keyboard. 

On Workspace Window: 
Last command can be repeated and also use display 
menu and selection menu frequently used by clicking 
RMB on workspace window (as shown below). 

 
On Project/Layer Window: 

You can use quick menus for changing property of entities and exporting 
specific entities as clicking RMB on Project/Layer Window (as shown below). 

     
On running Operations: 

On running a specific operation, program usually waits your command input. At 
this time, you should click RMB on workspace window and select a specific 
menu as below. 
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Viewing & Displaying 
 

Workspace Window: 
 Bounding Box – a smallest rectilinear box that encloses a shell. When 

multiple shells exist, only one shell can be displayed in the desired color while 
others have a different color. This shell with a white bounding box is the 
Active Shell. 

 Axis – helps you visualize the orientation of shells in the workspace window. 
This is not the origin. 

 Grid – displays screen grid for visualization in workspace window 

 
Display Mode: 

Mode Icon Hot Key Explanation 

Point Set  F1 Draw only vertices 

Wireframe  F2 Draw edges of faces 

Hidden Line  F3 Draw edges visible from the current viewpoint 

Shaded  F4 Draw shaded faces 

Shaded with Edges  F5 Draw shaded faces with edges 

Transparent  F6 Draw shaded faces with transparency 

Textured  F7 
Draw texture mapped faces  

if the texture information is available 

Grid 
Axis 

X: red 
Y: green 
Z: blue  

Bounding 
Box 
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Working view volume management : 
This operation is for displaying only the user-defined regions on the workspace 

window. 

[Menu] View > Set Working Region 

              
Polygonal model Selected View Volume Set Working Region 

View  Point: 
View point Icon Hot Key 

Front  Alt+1 
Back  Alt+2 
Left  Alt+3 

Right  Alt+4 
Top  Alt+5 

Bottom  Alt+6 
Iso  Alt+7 

 

Shading  Method: 

 
Flat Smooth Phong Shading Depth Cueing 
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Initialization of Perspective View 
You can toggle off the Perspective View option when a new workspace window is 
opened. Go to the Display Options tab after performing File > Preferences menu, 
and turn off it, on as default, at the Elements. Also it can be directly toggled on/off by 

clicking the perspective icon ( ) on the view toolbar. 
 
Customizable System Color 
The default shell color, surface rendering color, background, grid, dimension, 
bounding box and the colors of all entities can be changed. 
 [Menu] File > Preferences > Display Options > Color & Material 

 
Customizable Color Bar 
You can change the color arrangement of the color-coded map by these operations: 
Shell/Shell Deviation, Curvature Plot, or Face Angle Plot in the Measure menu, 
Curve/Shell Deviation in Curve menu, Surface/Shell Deviation or Curvature Plot in 
the Surface menu, Whole Deviation or Sectional Deviation in the Inspection menu. 
Also you can save your own color patterns and reload them for different 
visualizations. 
[Menu] View > Customize Color Bar 

Customizable Text Font 
You can change font, style, color and size of system text 
displayed on the viewing window by Inspection > 
Annotation > Add Note menu or Information menu. 
[Menu] View > Customize Font > Small Text / Large 

Text 

 
Real-time Color Map Representation 
If you move the mouse over the color map after performing operations for various 
deviation/curvature verifications, the values are represented on the color map in real-
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time. 
After you click the right mouse button on the color bar window, you can select sub 
menus, Continuous, Discrete, Go/No Go or Show Histogram. 

      
Point Shading 
The point shading can be activated by Shading Method > Point on the View menu 
and points are resized by the Point Drawing Size of Preferences. This operation 
uses the scan direction of a scanner if it is included in a file. In case the normal of 
shaded is wrong partially in a point cloud shell, the Filter Noise operation may solve 
the problem. 

Histogram 
The color bars of Shell/Shell Deviation, Surface/Shell Deviation and Whole/Section 
Deviation (With Polygon) have an option called Show Histogram on the popup menu. 
It spreads on the right side of color bar with a distribution chart of deviation. The 
color of histogram can be customized by the View > Customize Color Bar menu. 

Selection by color map 
It is available to select faces or vertices by the min/max range of the deviation map. 
The color bars of Shell/Shell Deviation, Surface/Shell Deviation and Whole/Section 
Deviation (With Polygon) have sub menus called Select Faces and Select Vertices 
on the popup menu. It allows you to select faces or vertices within a specific range 
which values are default min/max deviations. 

User-defined View Positions 
You can rotate a model to specific position and save the view. You can also rename 
the saved view and remove it from the View Positions node of Project tree window. 
[Menu] View > Add Current View 

Environment Mapping 
This operation executes the environment mapping to evaluate the face quality on the 
polygonal model. The map is better if you select the “High Quality Normal” option in 
File > Preferences and turn on “Smooth Shading Mode” icon in the “View” toolbar. 
[Menu] Measure > Environment Mapping 

Face Angle Plot 
This operation represents the angle between the face normal direction and a user-
defined vector by the color map. 
As drawing curves along the boundary of the color map, you can define the parting 
line for mold making.  
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[Menu] Measure > Face Angle Plot 

Contour Lines 
This operation represents contour lines with color map on the model. This shows you 
positions that lie in same height from a reference plane. 
[Menu] Measure > Contour Lines > Shell/Model 

 
Show/Hide Curve/Surface with Shell 
You can set the display option to On/Off so that all the connected curves/surfaces 
are shown or hidden when a shell is shown or hidden. 
[Menu] Curve(Surface) > Property > Show / Hide with Shell 

Ref. Geometry 
1. Show/Hide Name: Using the RMB menu in the project tree window, you can 

show or hide the name of reference geometries in workspace. 
2. Render Ref. Geometry: It determines to render reference plane, sphere, and 

cylinder. This option is in Display Options tab of Preferences. 
3. Depth-Test Ref. Geometry: If the depth test is enabled, reference geometry 

is displayed while shells are hiding its part. This option is in Display Options 
tab of Preferences. 

Layer Management 
1. When Arrange Layers by Shell is selected in layer tree window, 

curves/surfaces/loops are automatically re-arranged to user-defined layers 
classified by connected shells. 

2. You create a new layer with curves(surfaces) selected by mouse drag after 
performing Curve(Surface) >Tool > Create Layer Node command. A new 
layer named "New Curve(Surface) Node" is registered on the bottom of the 
layer tree and the selected curves(surfaces) move to the new layer. 
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Trackball & Transformation 
 

Virtual Trackball : 
This operation is applied to the entire model, all shells on the workspace 

window. 

But the model is not transformed but only view point is changed. 

Rotate LMB(Left Mouse Button) or four arrow keys 

Zoom  SHIFT + LMB or Up/Down arrow keys, wheel 
mouse 

Mouse Control 
or 

Keyboard 
Pan CTRL + LMB(Up/Down direction) or four arrow 

keys 
 

Shell/Coordinate Trackball : 
This operation is applied to a selected shell or coordinate system and its 
coordinate values are transformed. 
 

[Menu] Edit > Transform > Shell Trackball, 
Ref. Geometry > Transform > Coordinate > Coordinate Trackball 

Mouse Control Rotate LMB 

 Pan CTRL + LMB 

 Depth Move CTRL + SHIFT + LMB(Up/Down direction) 
 

Manipulator Translate LMB + Left(-)/Right(+) direction on arrow 

 Rotate LMB + Left(-)/Right(+) direction on circle 

 
 

Y-axis translation 

X-axis translation 

Z-axis translation 

X-axis rotation 

Y-axis rotation 

Z-axis rotation 
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Curve Template Trackball : 
[Menu] Template > Tool > Transform 

Manipulator Translate LMB + Left(-)/Right(+) direction on arrow 

 Rotate LMB + Left(-)/Right(+) direction on circle 

 Scale LMB + Left(-)/Right(+) direction on box 

 
 

Changeable Trackball Center 
You can change the trackball center to a user-defined position on the model. This 
viewing operation enables you to rotate an object discriminatingly while focusing on 
a part of it. 
[Menu] View > Set / Reset Trackball Center 
 
Shell/Model Transformation : 
[Menu] Edit > Transform > Shell / Model 

 Rotate – rotate a shell/model as given angle around specific axis 
 Translate – translate a shell/model as given distance in the x, y, or z direction 
 Scale – increase or decrease the actual size of a shell/model 

 
Coordinate Transformation : 
[Menu] Ref. Geometry > Transform > Coordinate > Transform Coordinate 

 Translation – translate a coordinate as given distance in the x, y, or z 
direction of absolute coordinate or user-defined coordinate 

 Rotation – rotate a coordinate as given angle around specific axis of 
absolute coordinate or user-defined coordinate 

Y-axis translation 

X-axis translation 
Z-axis translation 

X-axis rotation 

Y-axis rotation 

Z-axis rotation 

Y-axis scaling 

X-axis scaling Z-axis scaling 
Global scaling 
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Selecting & Deleting 
 

Commands: 
 Select Entities – Vertex, Face, Shell, Curve, Surface, Loop  
 Select All / None / Inverse – Vertex, Face 
 Select Custom Region – Face 
 Select Flood Fill – Face 
 Select Boundary – Vertex, Face 
 Select Around Curve/Surface – Vertex, Face 
 Select Enlarge Depth/Feature region, Shrink One Depth – Face 
 Select Visible / Through / Active Shell Only – Vertex, Face 
 Select Mode – Line, Rectangle, Circle, Polyline, Freehand, Paint Brush 

 
Selection Method: 

 Picking – single selection,  

 Freehand – Vertex, Face, Control Point, Node,  

 Paint Brush – Vertex, Face, Control Point,  
(NOTE: By Paint Brush, visible vertices, faces, or surfaces only are selected, 
in case of polygonal or surface model) 

 Crossing – Multiple Selection, Vertex, Face, Shell, Curve, Surface, Loop,  

NOTE: To selectively deselect entities, press the Ctrl key while selecting entities 
from the current highlighted selection. 

 
Selection Option: 

Option Menu Selection Result 

No option 
 

  

Visible Only 
 

  

Through 
 

  
Note: If a shell is a point cloud without faces, vertex selection follows the selection 
options, Select Visibles Only and Select Through in the point shading mode. 
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Selecting Surface 

The surface selection method provides you with a way to select only visible 
surfaces while they are in a rendered state. You can use the Select Visibles 
Only and Select Through selection options to select surface in the same way 
you can select vertices and faces. When the surfaces are not rendered, the 
selection is accompanied by picking one of iso-curves on a surface as a 
single selection and by dragging mouse across iso-curves of surface as a 
multiple selection. All surfaces can be selected at a time using the rectangle 
selection mode.  When surfaces are rendered, you can select using either the 
paint brush mode or the rectangle mode, and the Select Visibles Only and 
Select Through options function in the same way as they do for vertices and 
polygons. Even in the paint brush mode, if the surfaces are not rendered, the 
surface selection is automatically accompanied by the rectangle mode. 

 
Deleting: 

 Single Entity – (i) Vertex, Face, Shell: Edit > Delete or Delete key 
                                     (ii) Curve, Loop, Template, Surface, Solid: 

[Menu] > Delete or Delete key 
 Multiple Entity – Vertices, Faces, Curves, Loops or Surfaces can be deleted 

by directly performing each Delete command after selecting each entities 
 
Selecting & Deleting on Project Window: 

 Single Entity – pick each node with LMB, and select Delete on RMB menu. 
 Multiple Entities – pick an upper rank node with RMB and select Delete All 

on RMB menu or pick multiple nodes with LMB while holding Shift or Ctrl key 
and select Delete on RMB menu. 

 Shown Entity Deletion – pick an upper rank node with RMB, and select 
Delete Shown Entities on RMB menu. 

 
Mark: 

It marks specific edges or vertices so that they are not affected by editing 
operations such as smooth, subdivide, re-mesh and etc. 

 Edges – edges on the shortest path passing selected vertices 
 Sharp Edges – edges constructing less than or equal to a given angle 

between two adjacent triangles 
 Boundary Edges – edges on a boundary 
 Vertices – picked vertices 

 
Mirror system: 

The mirror selection system allows a user to select the corresponding faces or 
vertices on the opposite side for a symmetrical object. 
The Apply Mirror Plane command is an On/Off toggle menu for applying a 
symmetrical selection system. A user has to indicate a reference plane created by 
Calculate Mirror Plane or Ref. Geometry > Create > Plane. When a user 
selects faces or vertices, its corresponding are automatically selected. 



 

 
 

4-19 

 Calculate Mirror Plane – creates automatically a reference plane 
corresponding to the plane of symmetry of a complete object. 

 Apply Mirror Plane – an On/Off toggle menu for applying a symmetrical 
selection system. 

 
Picking Point: 

When select a point on an object using functions such as measuring, creating ref. 
geometries or creating interpolation curves, you can choose one of these point 
types: point(on face), vertex, ref. point, point on surface, or point on curve. 

 Point – anywhere position on a face 
 Vertex – an intersection point that edges meet each other 
 Ref. Point – a user-defined point 
 Point on curve – a point on a curve 
 Point on surface – a point on a surface 

Note that the “point on surface” option requires true color display and surface 
rendering information, therefore render a surface before select this option or the 
opened mdl file should have rendering information already. 
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Reference Geometry 
 
Reference geometries are point, vector, plane, circle, sphere, cone, box, torus and 

coordinate which are introduced for various purposes such as dividing, making 
volume, slicing, section viewing, measuring, transformation, alignment, etc. 

Reference geometries are listed on Project window, and can be managed through 
the corresponding object pop-up menu. You can edit the coordinate values on the 
Project window.  

The colors of reference geometries can be specified by user at File > Preferences. 
When you transform a reference coordinate, a shell, which is connected to the 

coordinate, is also transformed. Also other reference geometries bound to the shell 
are transformed. 

Reference geometries are often used by the following operations: 
 

Point: 
Pick Point on every operation 
Build > Register > 2 Shells > Pick 3 Ref. Points 
Measure > Distance/Radius/Angle 
Measure > Auto Measure 
Curve > Create > Interpolate 

Vector: 
Build > Register > Rotary Table 
Edit > Add > Shell > Cylinder > From Ref. Vector 
Edit > Add > Shell > Cone > From Ref. Vector 
Tool > Fit Regions To > Cylinder 
Measure > Angle 
Curve > Create > Slice 
Curve > Create > From Ref. Geometry > Vector 

Plane: 
Select > Mirror System > Apply Mirror Plane 
Edit > Vertex > Pick On Plane 
Tool > Extend Region 
Tool > Divide/Mirror 
Tool > Make Volume > Extrude to Plane 
Tool > Fit Regions To > Plane 
Measure > Distance/Angle 
Measure > Cross Section > Shell/Model 
Curve > Create > Slice 
Curve > Create > Mirror 
Surface > Create > Mirror 
Surface > Create > From Ref. Geometry > Plane 

Circle: 
Edit > Add > Shell > Cylinder > From Ref. Circle 
Edit > Add > Shell > Cone > From Ref. Circle 
Curve > Create > From Ref. Geometry > Circle 

Sphere: 
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Tool > Fit Regions To > Sphere 
Surface > Create > From Ref. Geometry > Sphere 

Coordinate: 
Edit > Transform > Shell/Model 
Measure > Cross Section > Shell/Model 
Curve > Create > Slice 
 

Cylinder: 
Edit > Add > Shell > Cylinder > From Ref. Cylinder 
Tool > Fit Regions To > Cylinder 
Surface > Create > From Ref. Geometry > Cylinder 

Cone: 
Edit > Add > Shell > Cone > From Ref. Cone 
Tool > Fit Regions To > Cone 

Box: 
Surface > Create > From Ref. Geometry > Box 

Torus: 
Surface > Create > From Ref. Geometry > Torus 
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Measure 
 
You can measure the distance, radius and angle. Also, there are useful functions for 
three-dimensional quantitative measurements such as cross section viewing, 
curvature plot, etc. You can also get the model information such as the object size, 
area, volume, and numbers of entities. 
 
Distance: 

 Point / Point along line 
 Point / Point along surface 
 Point / Vector 
 Point / Plane 
 Plane / Plane 
 Perimeter with Point and Plane 
 Perimeter with Points 

Radius: 
 Circle 
 Sphere 
 Rounded Area Radius 

Angle: 
 Plane / Plane 
 Plane / Vector 
 3 Points 
 2 Vectors 

Cross Section: 
 Perimeter 
 Area 
 Centroid 
 Distance and displacement between points 

Auto Measuring: 
 Landmark based, automatic dimension calculation 

Deviation: 
 Shell/Shell, Curve/Shell, Curve/Curve, Surface/Shell, Point/Surface, 

Point/Polygon, Point/Curve 
Curvature: 

 Mean, Gaussian, Maximum and Minimum 
 
NOTE: You can convert the deviation or curvature color maps to the vertex color of 

objects. For example, it is possible to draw feature curves on polygonal 
surface while viewing the curvature color map. 
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Undo 
  

You can use the Undo command to removes the effects of the last operation 
performed. 

To perform the Undo command, a saving space called command stack is required. 
The Size of the command stack means the maximum number of recent commands 
undoable. There is no limit to the size of the command stack in Pixform Pro. You can 
record and undo commands as many times as the memory permits. But, the larger 
the size of the command stack, the weaker the performance. Therefore, setting a 
practically appropriate command stack size is important. To set the size of the 
command stack select File > Preferences menu, and change the value of Undo 
depth item in the General Options tab. 

Undo depth configures the size of the command stack to return an object to the 
state it was in before the last action.  

 
The Undo command, disabled by default, can be enabled or disabled alternately 

by clicking  icon in the standard toolbar or by clicking Edit > Enable Undo menu 
in toggle type. Only when Undo is enabled, recently executed operations are 

recorded. To undo an operation, click Edit > Undo in the menu bar or  icon in the 
standard toolbar or push the hot key, Ctrl+Z. 

 
If you want to enable the Undo operation by default, check the Enable Undo 

option in the General Options tab of File > Preferences menu. 
The Undo command is available for most operations except for the follows: 
-. Selection 
-. Viewing 
-. Measuring 
-. Inquiring Information 
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Preferences 
 
You can change a variety of Pixform Pro’s default settings to customize the 
application and accommodate your personal work style and needs. All of the options 
can be accessed by selecting File > Preferences menu. 
 
General Options: 

 Enable Undo – configures whether to enable or disable the Undo operation 
when Pixform Pro is launched or File > New menu is selected. 

 Undo depth – configures the size of the command stack to return an object 
to the state it was in before the last action. For enabling or disabling this 
option, you should click Edit > Enable Undo menu in toggle type. 

 Auto save – makes the current model save automatically at regular intervals 
in minute. This option can be enabled or disabled by checking or un-checking 
the small box in front of this item. 

 Default MDL file – includes all the option settings of Preferences and 
material colors you defined. It originally locates in the Pixform Pro home 
directory as a default model file (rfDefaultModel.mdl) and a user can change it 
to his desired folder. When you launch Pixform Pro, the parameters of the 
default model file are automatically loaded. You can save your own default 
model file by Save as Default MDL of File menu to the desired directory of 
file. (Note: You can use this default model file when you do New and Import 
models, but if you do Open a model, you should use the parameters in the 
model. 

 Cache Directory – is where the automatically saved file(MDLAutoSave1.mdl) 
and all the temporary files locate. 

 Number of recent MDL files – is the number of recently worked file list 
shown beneath File > Recent Files. 

 Function of middle mouse button – enables you to allocate Pause or Done 
function to the middle mouse button. 

 External Data Unit – is the unit of external model imported through File > 
Import command, and used as the basic unit of numerical input while 
executing commands such as Transform, Delete Spikes, etc. 

 Internal Measure Unit – is the unit used internally within Pixform Pro, and 
used as the basic unit for showing information while executing commands 
such as Measure, Information, etc. 

 Significant position of the decimal – controls the decimal place, which 
affects all the numbers displayed in the working window, command console 
window, color map, deviation, dimension, and so on. 

 
Display Options: 

 Polygon draw – Offset factor and Offset unit are parameters used when 
displaying shells with Shaded with Edges or Hidden Line rendering mode. 
In case edges do not look clearly, up or down the values of these parameters. 
The phenomenon arises from incompatible graphic driver. 
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 Picking – configures the size of the rectangle in the pixel unit, and it affects 
the accuracy of picking result. Turn on the Vertex snap option to pick a vertex 
when you pick a position close to it. 

 Show at launch – decides whether or not to show the bounding box, axis, 
and grid on the screen and to apply perspective viewing to models when a 
new workspace window is opened. 

 Select – is used to select only faces that are visible on the screen.  
 Light – is the light source 

used when displaying shells 
with Shaded or Transparent 
rendering mode. The 
positions of each light source 
are shown as right 

 Dynamic Draw – is used to 
increase the performance of 
virtual trackball 

 Gradient Background – sets 
the default background color 
of Workspace window to 
gradient gray color. 

 2 Side Shading – is used to 
render both sides of polygons 

 High Quality Normal – 
enables objects to be shaded smoothly by considering the connection 
relationship among faces with original normal vectors of faces on polygonal 
model 

 Render Ref. Geometry: It configures to render reference point, plane, sphere, 
and cylinder. 

 Depth-Test Ref. Geometry: If the depth test is enabled, reference geometry 
is displayed while shells are hiding its part. 

 Point Drawing Size: It configures the size of vertices when the point shading 
is active. 

 Color & Material – is used to change the colors of a default shell color, a 
rendered surface, reference geometries, background, grid, dimension, 
bounding box, showing boundary and all entities. 

 
File I/O Options: 

 Shell Merge Options – configures whether or not to preserve the original 
shell structure of the model. 

 IGES Import Options – Tolerance configures the tolerance used when 
reading IGES format files. Use Unit Information determines whether use the 
unit of an IGES file imported. Surface Healing remedies the normals of 
surface patches and repairs small gaps and other flaws when an IGES file is 
opened. Merge boundary curves determines whether merge G1 tangent 
curves in a connected loop which is a boundary of a trimmed surface patch. 

 Import Material Information – determines whether to include material 
information such as texture or vertex color when a file is imported. 

 Check Integrity Error – configures whether or not to clean non-manifold 
faces, coincident vertices and zero area faces when a file is imported. 
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 Executable File Formats by Double-Click – determines to open a specific 
file format by double-clicking it on an explorer window. (Note: This setting is 
saved into the registry of Windows system, not to a default MDL file) 

 
Curve/Surface Options: 

 Tolerance – configures the tolerances used for curve merging, surface 
intersection, surface area and all trim operations. If need more accuracy, the 
tolerance should be reduced. 

 Shell-Curve distance tolerance on creation – sets tolerance between a 
shell and curves when curves are created. 
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Hot Keys 
 
The hot keys provide quick access to the most commonly used commands. 
Keyboard shortcuts offer an alternative method of performing actions for users who 
prefer the keyboard to the mouse. Some of the commands in Pixform Pro are 
assigned hot keys by default. 
You can also change the existing hot keys or create new hot keys for commands that 
do not have hot keys by default. For this purpose, use the Keyboard tab on the 
Customize dialog box after executing View > Toolbars > Customize menu. You can 
assign more than one shortcut key for any command and delete or change key 
assignments. You can also reset all shortcut keys to their default settings. 
The following is the list of default hot keys in Pixform Pro. 

File menu   View menu  
File Open Ctrl + O  Zoom Window Shift + Z 
File Save Ctrl + S  Zoom Previous Shift + X 

Select menu   Reset View Ctrl + R 
Select Vertex Shift + V  Point Set Display F1 
Select Face Shift + F  Wireframe Display F2 
Select Shell Shift + S  Hidden Line Display F3 
Select All Shift + A  Shaded Display F4 
Select None Shift + N  Shaded With Edges Display F5 
Select Inverse Shift + I  Transparent Display F6 
Select Enlarge One Depth Shift + E  Textured Display F7 

Edit menu   Front View Alt + 1 
Undo Ctrl + Z  Back View Alt + 2 
Delete Vertex Alt + V  Left View Alt + 3 
Delete Face Alt + F  Right View Alt + 4 
Delete Shell Alt + S  Top View Alt + 5 
Copy Ctrl + C  Bottom View Alt + 6 
Paste Ctrl + V  ISO View Alt + 7 
Shell Trackball Ctrl + T  Show / Hide Bounding Box B 
Edit Material Ctrl + M  Show / Hide  Axis A 

Show/Hide Keys   Show / Hide  Grid G 
Show/Hide All Shells 1 / 2  ETC  
Show/Hide All Curves 3 / 4  Repeat Last Command Space 
Show/Hide All Surfaces 5 / 6  Default Esc 
Show/Hide All Loops 7 / 8  Pause P 
   Show Boundaries E 
   Render Surfaces R 
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Using On-line Help 
 
There are two ways you can access on-line help. You can open the Help window 
and search for information on a specific topic, or you can use context-sensitive help. 
 

To access help for any commands, select Help > Pixform Pro Help menu or  
icon on the Standard toolbar. Go to the Menu description to find the menu structure. 
To access context-sensitive help for some commands, first select the desired menu. 

When the dialog box is displayed for the command, press  button. The 
corresponding help page for the function will be displayed. 
Pixform Pro provides an additional on-line help for Pixform Pro API. To access this, 
select Help > Pixform Pro API Help menu. 
 
To open a PDF tutorial on-line, click Help > Pixform Pro Tutorials menu. It needs 
that a Acrobat Reader should be installed on your computer. 
 
To check the version of your Pixform Pro, click Help > About Pixform Pro… menu 
or just type “about” in the command prompt. 
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5.  Scan Workbench 
 
Scan workbench handles point-based processing. Pixform Pro accepts point clouds 
or polygon meshes from 3D scanners. There are many operations to improve the 
scanned data. Using them can quickly and conveniently clean up point clouds. Noisy 
data can be improved and intelligent filtering routines can be employed to reduce the 
count of the point set. Unnecessary or erroneous data captured during scanning can 
be eliminated. The smaller improved point set will polygonize more rapidly and result 
in a higher quality polygonal surface.  
When the data includes polygon meshes, you may go to the registration process 
directly. If not, you should begin at the triangulation process. If use a scanning 
device with a global positioning sensor, you may skip the process of Registration of 
2 shells. 
Especially in case of large point data, you may skip the triangulation process and 
directly go to the registration and merging process. 
 
Work Process: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Point 
Clouds 

Polygon 
Meshes 

Filter Noise 
Filter Redundancy 
Sampling Points 
Smooth Points Triangulation 2D/3D 

Registration of 2 shells Global Registration Merge Shells 

Other Processing 

Rotary Table 
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Filter Noise 
You can remove points placed in undesirable regions due to measurement errors. 
You can repeatedly use Build > Filter Noise menu. 
 
NOTE: While noisy data will be gradually removed in every time it is used, too many 
repeat may remove the correct data as well. 
 
Exercise: 

1. Open “noise.mdl” under “scan_wb” folder. 
2. Apply Build > Filter Noise a few times with default options. 

   
Before filtering noise After filtering noise 

For point set that cannot be removed by this operation, you can remove them 
manually by Edit > Delete > Vertex menu. 
 
Filter Redundancy 
You can uniformly reduce the number of points in a point set which points are too 
close or overlapped each other. This operation, Build > Filter Redundancy, deletes 
only points which distance to adjacent points is smaller than mean distance between 
all points. 
Filter Redundancy is very useful when you triangulate point set having overlapped 
points or scanned repeatedly.  
 
Exercise: 

1. Open “filter.mdl” under “scan_wb” folder. 
2. Apply Build > Filter Redundancy twice with default value. 
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Point set before filtering   Point set after filtering 

 
Sample Points 
The Uniform sampling operation performs a random sampling of point set. Before 
sampling, you can determine the percentage of total points you want reduced, and 
the application removes them automatically. The Line/Grid option is suitable for a 
line/grid type point cloud. The Curvature sampling operation reduces points based 
on the curvature. Points in a high curvature region are less deleted than low 
curvature region in order to maintain the accuracy of curvature line, but points in flat 
regions are much more likely to be deleted because those regions require less detail. 
 
Exercise 1: 

1. Open “sampling.mdl” under “scan_wb” folder. 
2. Apply Build > Sample Points > Uniform. 
3. Type in 40 %, and click OK with General type. 

                    
  Before sampling points         After sampling points 
 
Exercise 2: 

1. Open “curvature_sampling.mdl” under “scan_wb” folder. 
2. Apply Build > Sample Points > Curvature. 
3. Type in 40 %, and click OK. 
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  Before sampling points   After sampling points 
 
Smooth Points 
Smooth Point operation smoothes point clouds for reducing roughness. This 
operation, Build > Smooth Points, removes noise from scanned data without 
reducing the count of points. You can use this tool to lessen sharp features or 
remove projecting points. 
 
NOTE: Too much smoothing can result in excessive loss of detail.  
 
Exercise: 

1. Open “smooth.mdl” under “scan_wb” folder. 
2. Apply Build > Smooth Points. 
3. Type in 0.5 weight and 10 iterations, and select OK. 

             
      Before smoothing       After smoothing 
 
Thin Points 
The Thin Points operation thins a selected point set and fits points to a curved line. 
The operation is useful for fitting a linear point set to a curve. 
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Exercise: 

1. Open “thin_points.mdl” under “scan_wb” folder. 
2. Click Measure > Point/Point Distance menu.  Click Vertex on RMB menu. 

Select two vertices as shown below left. 
(Distance will be referred as Search Radius in the step 4) 

3. Click Build > This Points menu, and select the point cloud. 
4. Type in 5 in Search Radius for Near Vertices. 
5. Click OK. 
6. Repeat this operation by typing in 3 Search Radius. 

                     
Original point cloud                                  Thinning points 

 

Dither Points 
This operation get a dithered point cloud from a texture polygon model by dithering 
its texture with the brightness and contrast. It results in denser point cloud over bright 
region and coarser point cloud over dark region. 
 
Exercise: 

1. Open “dither.mdl” under “scan_wb” folder. 
2. Click Build > Dither Points and pick a shell. 

        
                         Original point cloud                            Original texture 
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3. Move slide bars as three steps for Brightness and Contrast to the right as 
below left picture. Then click Dither Texture button. 

4. Finally, click OK button. 

      
                   Modified brightness & contrast               Dithered point cloud 
 
Point Cloud to Polygon (2D Triangulation) 
Polygonal model consists of open or closed surface containing triangles(faces), 
edges and vertices. You can get a polygonal shell as triangulating a point cloud 
scanned on a single view via Build > Triangulate > Surface > 2D. This operation 
projects points on three dimensional space onto two dimensional plane and then, 
apply Delaunay Triangulation process to projected points. Thus, for proper 
triangulation, all the points must be projected onto a plane without overlap. If a point 
cloud consists of 3D shape scanned by automatic aligning system such as CMM, go 
to the full 3D triangulation command. 
 
Exercise: 

1. Open “venus_point.mdl” under “scan_wb” folder. 
2. Show only “front” in project tree window. 
3. After applying Zoom Window to a specific area, measure the diagonal 

distance between adjacent points by Measure > Point / Point Distance. It 
should be near 3.0. 

4. Show all shells by pushing 1 hot key. 
5. Select Build > Triangulate > Surface > 2D menu, and select all shells by 

mouse drag. 
6. Type in 4.0 Maximum edge length option. Turn on Facing angle option, and 

select OK. 
7. Push F4 hot key, and select View > Explode Shells icon. 
8. Apply Change Material to all shells using RMB menu on project tree window. 
9. If necessary, push E hot key, and check polygon shells. 
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Before polygonizing         After polygonizing 

 
Registration of 2 Shells 
Registration allows you to register multiple point clouds or polygonal shells using 
overlapping regions. If multiple scans were taken to obtain various views of a 3D 
object, you need to properly align all of the scans within the viewport to construct the 
original object. 
Registration is accomplished by identifying known features common to two datasets. 
This application calculates an approximate position of one shell with respect to 
another using common geometric features between two shells. When performing this 
operation, first selected shell is moved to second selected shell. 
 
NOTE: The application shows you a multiple window system to view individual shells 
and easily pick reference points during registration. If you don’t want to separate the 
window, turn off the option Show Each Shell Separately in the Build > Register > 
Options menu. In this case, you have to manually separate each shell using Shell 
Trackball. 
 
Exercise: 

1. Open “venus_polygon.mdl” under “scan_wb” folder if necessary. 
2. Click Build > Register > 2 Shells > Initial menu and pick “right” and “front” in 

turn in project tree window. 
(NOTE: The “right” shell will be transformed to the “front” shell) 

3. Rotate shells in each viewport in the same direction after clicking Pause on 
RMB menu as shown below. 

 
4. Pick more 3 pairs of corresponding points in each viewport as shown below. 
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5. Click Done on RMB menu. The “right” shell was transformed to the “front” 

shell. 
6. Repeat the above process with “left” shell as a first selected shell and “front” 

shell as a second selected shell as below left. So, the “left” shell should be 
transformed to “front” shell. 

7. As a result, three shells are registered each other as below right. 

                 
 
Global Registration 
Global Registration exactly matches the position of all the selected shells at the 
same time using the overlapped region, which is automatically found. When the 
overlapped region is too little or the two registered shells are located far from each 
other, the registration result may be poor. 
 
NOTE: To change the default parameters used in this operation, you can change the 
values of Num. Of Max. Iteration and Max. Average Deviation in the Build > 
Options > Set Register Options menu. 
 
Exercise: 

1. Open “venus_register_initial.mdl” under “scan_wb” folder if necessary. 
2. Show all shells in project tree window.  
3. Select Build > Register > Fine menu, and select All on RMB menu. 

(NOTE: All means all the shells shown in the workspace window. If you 
register globally only a few shells, hide other shells on project tree window 
before performing Global Registration operation) 

4. Evaluate the registration result by Measure > Cross Section > Model menu. 
Move Position slide bar to the nose of model as shown below left, and turn 
on Hide front option in the dialog box. Zoom in the nose part, and measure 
the distance between two sections as below right after clicking Dist. button. 
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5. To evaluate the registration by another tool, select Measure > Shell/Shell 

Deviation menu and then select two shells. Push RMB on color bar and 
select Show Histogram. You will see a distribution chart of deviation. 

 
 

Regional Registration 
You can align exactly two shells which having common region partially. The 
advantage is to enable you to align two same objects though an old one is different 
from a new one partially because it is changed after a period of time goes by. 
 
Exercise: 

1. Open “teeth_region.mdl” under “scan_wb” folder. 
2. Click Build > Register > 2 Shells > Initial menu and pick “base” and “teeth” 

in turn in project tree window. 
3. Pick more 3 pairs of corresponding points in each viewport as below and click 

OK on RMB menu. 
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4. Click Build > Register > 2 Shells > Regional menu and pick “base” and 

“teeth” in turn in project tree window. And then select region on the shell 
“teeth” as below middle. Click OK on RMB menu. 

        
Initial aligning                    Selecting common region  

5. Click Measure > Shell/Shell Deviation menu and pick “base” and “teeth” in 
turn in project tree window. Set Cal. Tolerance to 10, click Apply, and hide 
all shells. 

      
Regional aligning                     Shell/Shell Deviation 

 

Surface Merging 
This operation merges shells which have been aligned by registration process into 
one united shell. During the merging process, overlapped regions between shells are 
removed and neighboring boundaries are stitched together with newly added 
polygons. The result and accuracy of shells are still maintained after merging. 
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NOTE: Before executing this operation, click the Enable Undo Icon ( ) to make the 
rollback functionality possible. 
 
Exercise 1: 

1. Open “venus_register_fine.mdl” under “scan_wb” folder if necessary. 
2. Show all shells in project tree window.  
3. Select Build > Merge > Meshes > Surface, and select All on RMB menu. 

 
 
NOTE: The Merge Shells operation enables you to change a default parameter for 
merging shells in the Build > Options > Set Merge Options menu. A thin wall 
object is partially broken after merging process because the thickness is thin. You 
can control a decision criterion for whether two shells are merged or not, by entering 
the value ranging from 0.0 to 1.0. 
 
Exercise 2: 

1. Open “thin_wall.mdl” under “scan_wb” folder. 
2. Click Measure > Cross Section > Model menu. 
3. Select X-axis and Sections only option, and click Dist. 
4. Click Min. Distance on RMB menu, and select two points as shown below 

right. 
5. Click Build > Merge > Meshes > Surface and click All on RMB menu. 
6. Press E key and rotate the merged shell to check the result. 
7. Open “thin_wall.mdl” again. 
8. Click Build > Options > Set Merge Options menu. 
9. Select Manual Distance Criterion option, type in 0.5, and click OK. 
10. Repeat the above step 5, and then compare the result of step 6. 
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Scans of thin object                            Check thickness of thin wall 

                      
Merging with default option                 Merging with 0.5 parameter 

 
Volume Merging 
This operation merges multiple shells into a single one by allocating their geometry 
information to a reference voxel model with a volumetric method. Volume based 
merging is useful when surface based meshing creates poor merge results. This 
polygon merging tool helps you to merge scan data with many holes and messy 
boundary, or bad aligned data. 
 
Exercise 1: 

1. Open “volume_merge1.mdl” under “scan_wb” folder. 
2. Click Build > Merge > Meshes > Volume, and select All on RMB menu. 
3. Set Resolution to 1 by default and check Optimize Mesh option. 

Note: Resolution is ratio to the average of vertex spacing. If the number is 
larger than 1, the edge length of merged shell will be larger than the average 
edge length of selected shell 

4. Click OK. 
5. Try to apply Build > Merge > Meshes > Surface to the same model and 

compare with each other. 
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Before merging After merging 

Exercise 2: 
1. Open “volume_merge2.mdl” under “scan_wb” folder. 
2. Click Build > Merge > Meshes > Volume, and select All on RMB menu. 
3. Set Resolution to 1 by default and check Optimize Mesh option. 
4. Click OK. 
5. Push F5 key and check polygonal meshes. 

    
Before merging                                       After merging 

6. Compare with the result by Build > Merge > Meshes > Surface. 
 
Merge Point Clouds 
The Merge Point Clouds operation merges selected shells and makes them into a 
point set. During the merging process, overlapped regions between shells are 
removed effectively. 
 
Exercise: 

1. Open “point_merge.mdl” under “scan_wb” folder. 
2. Click Build > Merge > Point Clouds menu, and click All on RMB menu. 
3. Click OK with Merge Shells option. 
4. Click File > Preferences, and go to Display Options tab. Set Point Drawing 
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Size to 3 and then click OK. 

    
Overlapped two shells                               Merging points 

 
Combine Shells 
The Combine Shells operation combines shells simply into one united shell. By the 
combining process, overlapped regions between shells remains as it is. This 
command is useful for making simply a large model from many scan data for the 
purpose of inspection because it doesn't need much memory 
 
Exercise: 

1. Open “point_merge.mdl” under “scan_wb” folder. 
2. Click Build > Combine Shells menu, and click All on RMB menu. 
3. Press F5 key. 

               
Overlapped two shells                               Combining shells 

 
Registration using Ref. Point 
This operation registers two shells by user-defined reference points as another 
method of the Registration of 2 shells operation. The reference points can be defined 
by the features of object like circle or by scanning reference balls around object.  
 
Exercise: 

1. Open “teeth_frame.mdl” under “scan_wb” folder. 
2. Select Build > Register > 2 Shells > Pick 3 Ref. Points menu, and select 

“frame” and “base” shells in turn. And then, pick pre-defined 3 pairs of 
reference points in order of number with starting from “frame” shell as shown 
below left. 

3. As a result, “frame” shell is transformed to “base” shell (as shown below right). 
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Rotary Table 
You can register and merge quickly multiple scans using a rotary stage. You should 
scan one shot of datum ball composing two spheres as shown below left before you 
scan a real object (as shown below right). The scan view of one shot is used to 
define the rotation axis of rotary table. 

                 
 
Exercise: 

1. Open “rotary_scan.mdl” under “scan_wb” folder. 
2. Show “datum_ball” shell only on project tree window. 
3. Select all vertices of upper sphere by Shift + V key, and find the center point 

of upper sphere by Ref.Geometry > Create > Point > Fit Sphere. 
4. Unselect all selected faces by Shift + N key, and repeat above 3 step for 

lower sphere. 
5. Push Shift + N key, and create a vector to be the rotation axis of rotary table. 

Select lower and upper reference point in turn after performing Ref. 
Geometry > Create > Vector > Pick Points and selecting Ref. Point on 
RMB menu. 

                                     
     (1)                        (2)                        (3)                        (4) 

6. Show all shells, and select Build > Register > Rotary Table. 
7. Click Select Axis button on the dialog box, and click the vector. 
8. Set Rotation Angle into 45 degree (as shown below left). 
9. Click Select Shell button, and select all shells in order of number except 

“datum_ball” on project window. 
10. Turn on Triangulate menu, and type in 0.5 in Maximum edge length after 

pushing Triangulate option button. 
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11. Turn on Global Register and Merge Shell menus, and click OK. 
12. Apply Change Material to the merged shell as shown below right. 

          
 
3D Surface Triangulation 
This operation converts a merged point cloud of multiple scanning to a polygonal 
model. The model can consist of both closed surface encloses volume and triangles 
that do not bound volume. If point clouds have duplicate points or complex scanning 
patterns, you should reduce points by filtering operation like Filter Redundancy. 
 
Exercise: 

1. Open “car.mdl” under “scan_wb” folder. 
2. Apply Build > Triangulate > Surface > 3D to the car model. 
3. Check polygonal shape partially using Select Vertices on RMB menu and 

Preview button on the dialog box before applying to entire point cloud as 
shown below. 

        
4. If triangles are not bad, click OK button. 
5. Select Yes if the shaded image of polygonal surface looks correct. 
 
NOTE: Though you decided polygon’s normal direction is incorrect (as below left), 
you can invert its direction by Edit > Reverse Normal > Shell menu. 
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3D Volume Triangulation 
This operation creates a polygonal model from a point cloud by volumetric 
triangulation method that constructs polygon meshes by adding the topology 
information to a reference voxel model which possesses the geometry information of 
a point cloud. The volume triangulation allows you to get a clean polygon model from 
a messy point cloud even though vertices overlap each other. This operation creates 
a new polygonal shell while preserving a point cloud shell. Volume based 
triangulation is useful when surface based 3D triangulation results in poor mesh 
quality. 
 
Exercise: 

1. Open “dragon.mdl” under “scan_wb” folder. 
2. Check the mean distance between vertices by Build > Filter Redundancy. 
3. Click Build > Triangulate > Volume and select a shell. 
4. Set Edge Length to 0.5 and check Optimize Mesh option, then click OK. 
5. Press F4 key and check boundary edges by pressing E key. 

    
           Point Cloud                           After volume triangulation 

6. Compare with the result by Build > Triangulate > Surface > 3D. 
 



 

 
 

6-1 

6.  Polygon Workbench 
 
The Polygon Workbench offers the most comprehensive set of functionalities 
available to manipulate and prepare polygon mesh models for a variety of 
applications. It includes virtually every tool needed to create high quality polygon 
meshes for rapid prototyping, 3D graphics, or downstream applications like NURBS 
surfacing. Pixform Pro's powerful hole filling algorithms intelligently fill in missing data, 
and several methods for surface smoothing can repair common errors in 3D scan 
data. A plethora of 3D measurements can be taken, including surface area, distance, 
volume and others. 
 
Polygon workbench is specific to working with the polygonal model, such as cleaning 
abnormal polygon meshes, refining the surface by smoothing, re-meshing, or 
decimation and to prepare the polygonal model for rapid prototyping or NURBS 
surfacing. Polygon workbench includes the various polygonal mesh editing tools. 
You can refine the polygonal mesh to improve the quality of surfaces you will 
generate. However, the degree of accuracy of the surfaces is based on the quality of 
the original data. 
 
Polygon workbench handles polygon-based volume model for RP(Rapid Prototyping) 
application. RP applications require a closed, watertight surface with a defined 
thickness. Pixform Pro provides many useful operations for rapid prototyping works 
like thickening, extrusion, aligning and Boolean operations, and so on. 
 
Pixform Pro can write widely used rapid prototyping file formats, such as STL, DXF, 
CLI, SLI, and SLC so that you can interface directly slicing data file obtained from 
Pixform Pro with rapid prototyping systems. Using this process, you can quickly 
produce prototypes from scan data or surface geometry from other systems. This 
greatly shortens the production cycle between scanning physical prototypes, creating 
CAD models, and finally generating prototypes. 
 
Typical abnormal faces defined in Pixform Pro are as follows: 
-. Non-manifold face: When faces share three or more edge, it is 
called non-manifold topology. In a pure mathematical term, only 
two faces can constitute an edge to be a manifold topology. 
However, an edge with only one face is classified as a boundary 
edge in Pixform Pro and considered to be normal. 
The non-manifold faces may cause severe errors in various 
calculations, and even severe errors in other applications such as 
NC machining.  
The right upper figure shows an example of the non-manifold 
topology, where faces (V1 V2 V4), (V2 V4 V3), and (V2 V4 V5) 
are sharing the edge (V2 V4). 
-. Redundant face: Other than boundary vertices, the number of 
faces and edges that share the same vertex must be identical. A 
face violating this rule is called a redundant face. 
The right middle figure shows an example of a redundant face (V1 
V2 V3). 



 

 
 

6-2 

-. Crossing face: When edges sharing a vertex intersecting with 
one another, they are geometrically incorrect and their faces are 
called crossing faces.  
Explaining crossing face by an example, the edge (V2 V3) of face 
(V1 V2 V3) is crossed with the edge (V1 V4) in the right below 
figure.  
Although crossing face is not a topological definition nor may 

cause sever problems, they may cause errors in geometrical 
calculation and, therefore, must be corrected. 
-. Unstable face: When faces consist of one side and one loop like 
Moebius Strip, their edges are recognized as boundary edges but 
their loop may not a hole and cannot be filled. Their faces are 
called unstable faces and can be easily found and deleted. 
 
The typical work process is as follows: 
1. Clean Non-manifold faces, crossing faces and unstable faces 
2. Fill holes in a model that may have been introduced during the scanning process 
3. Edit or optimize polygonal surface using various tools like decimation, smoothing 
or remeshing for rapid prototyping, NURBS surfacing or downstream applications 
 
Clean 
You can automatically delete non-manifold faces and cross faces using Clean menu. 
You can also delete spike faces that may have been introduced during the scanning 
process using Delete Spikes menu. Fix Bad Normals operation searches and 
corrects all the faces, which their normals are reversed, during 3D triangulation 
process. Delete Singularities operation deletes several kinds of unnecessary data in 
a single command. 
 
Exercise: 

1. Open “helmet.mdl” under “polygon_wb” folder. 
2. Select Clean > Find Abnormal Faces menu. The below left shows non-

manifold faces detected and the below right shows crossing faces detected. 

   
3. Apply Clean > Clean Non-manifold Faces and Clean > Clean Crossing 

Faces. 
4. Check again abnormal faces by Clean > Find Abnormal Faces menu. 
5. Select Clean > Fix Bad Normals menu, and select a reference face whose 

normal is correct as below left. Then, select OK on dialog box. As a result, 
the shell is changed as below right. 
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Fill Holes (Surface) 
When the scan data is triangulated, holes or gaps can appear in the surface of the 
model. The Fill Holes operation fills holes in a model that may have been introduced 
during the scanning process. The operation constructs a polygonal structure to fill 
the hole, and both the hole and the surrounding region are remeshed so the 
polygonal layout is organized and continuous. 
You can fill holes with: automatically filling all holes; manually filling holes; and the 
combination of both. You may automatically fill all small and simple holes, and then 
bridge the large, more complex, holes manually. Bridging results in smaller holes 
which can then be filled based on the polygon around them. 
When the Fill Holes operation is activated, all boundary edges of holes are displayed 
with red color for easy identification, and you can choose to fill all of them or choose 
specific holes. 
NOTE: If there are holes which boundaries are not displayed as red color, they can 
be fixed by Clean > Fix Bad Normals function. 
There is a curvature based filling option that ensures the polygonal structure used to 
fill holes in curved regions is curved to match the surrounding area. 
 
NOTE: The Fill Holes operation can be applied an entire shell or locally selected 
region. 
 
Exercise: 

(Being continued) 
1. Apply Tool > Fill Holes > Surface to the shell, “helmet”. 
2. Pick a hole shown below right, and select OK with “Smooth” method. 

  
3. Change the viewpoint as shown below. 



 

 
 

6-4 

 
4. Select Bridge Hole on RMB menu, and select an edge on boundary of the 

hole as shown below left. Drag across a mouse pointer to another edge while 
holding down LMB (as shown below right). The other edge will become 
highlighted and a span of polygon should appear between the two edges. 

 
NOTE: Bridge Hole option is very useful when a hole is too large or complex 
to fill. 

     
5. To accept a bridge, release the mouse. A bridge is created between the 

starting edge and the destination edge (as shown below left). 
6. Select Done on RMB menu, and fill two holes of both sides with default 

option. 
7. Click Next button in the Hole Selection Options dialog box to find easily 

another holes, and fill it. 

      
8. Click Next button, and fill the hole with “Curvature” method. 

     
9. Select Quit on RMB menu to exit the operation. 
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Decimate 
You can reduce the count of polygon meshes to reduce the amount of surface detail 
captured. In areas where you do not need as much surface detail, such as flat areas 
or unnecessarily rough areas, you may wish to decimate your model. This operation 
reduces the number of triangles while preserving original surface shape. 
You can apply Decimate operation to multiple shells at the same time. In case of 
multiple shells, the Number of faces or Reduction Ratio is shared to all shells by 
same distribution ratio. 
The operation provides three options: Number of faces; Reduction ratio; and Error 
Bound. You can simply type in the number of faces or reduction ratio, which you 
want to reduce to. Use Error Bound option instead of number or percentage for the 
limitation of point movement during decimation. For example, if you type in 0.05 
Error Bound, maximum deviation error between original model and decimated one is 
lower than 0.05. 
The Don’t move original vertices option ensures to retain the positions of remaining 
vertices. The Don’t modify boundary edges option ensures the boundary edges are 
not moved when the operation is applied. The Try to preserve mesh quality option 
lets program perform more rigorous calculation for making the modified faces as 
uniform as possible. The Preserve Marked Edges/Vertices option allows marked 
edges/vertices to be maintained as it is. 
In case the model has several million of polygon meshes or more, you can reduce 
rapidly the count using the Large Data Decimation tool. The operation voxelizes a 
bounding box as a specific number of grid in the X, Y and Z direction, and reduces 
all points of each voxel to one point. The surface quality of polygon by the Large 
Data Decimation is not good compare to the High Quality Decimation, but the 
processing time is very short. 
 
NOTE: The Decimate operation can be applied an entire shell or locally selected 
region. 
 
Exercise: 

(Being continued) 
1. Apply Tool > Decimate > High Quality to the shell “helmet”. 
2. Reduce to 30%, and select OK. 

  
Before decimation After reducing to 30% 
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3. Check the number of triangles in project window and how shape is retained, 
despite a 70% reduction in polygon count. 

 
Smooth 
Sometimes scan data may have too much detail, for example, it may include every 
bump and detail of surface roughness in the scanning process. You can reduce this 
roughness by smoothing the polygon model. Smoothing flattens any curved portion 
of the polygon where the surface changes direction, including corners. Take care 
when smoothing the polygon, however, because excessive smoothing can result in 
too much loss of detail. 
The Smooth operation smoothes the surface of the polygonal model by changing the 
coordinates of the input vertices. The operation provides three methods: Laplacian, 
Loop and Curvature. The Laplacian method, selected by default, is a tool for 
enhance global smoothness while Loop method is a kind of local smoothing tool for 
keeping details of model. The Curvature method is used for curvature based 
smoothing. 
The smooth process is iterative, and you can designate the number of iterations. You 
can also control the degree of smoothness with weight factor. The greater number of 
iterations and the stronger of weight factor, the smoother the model becomes. 
However, too many iterations and too much weight may significantly alter the original 
model data. 
When applying the Smooth operation, you can deselect the Move Boundary Vertices 
option, selected by default, to ensure the boundary points are not moved. The 
Preserve Sharp Edges option allows sharp edges or feature lines to be maintained. 
The Preserve Marked Edges/Vertices option allows marked edges/vertices to be 
maintained as it is. If you check the Constrained Smoothing option, the shape quality 
of each face is enhanced but the speed is down. If you check the Preserve Volume 
option, the total volume of model will be preserved, thus prevent polygonal model 
shrinkage, during the smoothing process. 
 
NOTE: The Smooth operation can be applied an entire shell or locally selected 
region. 

Also you can use the paint tool to smooth locally in real time. 
 
Exercise: 

(Being continued) 
1. Change the viewpoint to view the inside of “helmet” as shown below. 
2. Select Tool > Smooth > Paint menu. 
3. Drag the paint tool while holding LMB to smooth any rough region. You can 

resize the paint tool by dragging LMB to left/right direction by holding down 
Shift key. 
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Before smoothing                                   Paint tool 

4. Push ESC key or select Done on RMB menu to complete this operation. 
5. Select faces as below right, and apply Tool > Smooth > Region to the 

selected region. 
6. Type in 3 iterations, and select OK with default options. 

            
After paint smoothing                               Selecting region 

7. Deselect all selected faces by Shift+N key to apply the Smooth operation to 
the entire shell.  

8. Select Tool > Smooth > Shell menu. 
9. Type in 3 iterations, and click OK with other default options. 

 
Subdivide 
The Subdivide operation improves the surface of the polygonal model by adding new 
vertices and adjusting the coordinates of existing vertices, resulting in a greater 
number of triangles in the selected area and a smoother surface. 
The operation subdivides selected triangles, producing three or four triangles for 
every one original triangle. Each face is subdivided into three or four triangles by 
adding new vertices on each edge of the face. You can select 3x if you want three 
new triangles to be produced and 4x if you want four; not only are the new vertices 
to be added but the original vertex position is also recalculated, thus the continuity of 
the curvature is much improved. 
You can subdivide only the faces which edges are longer than the length you specify. 
You can select the Preserve Sharp Edges option to maintain sharp edges or feature 
lines. The Preserve Marked Edges/Vertices option allows marked edges/vertices to 
be maintained as it is. This operation also enables you to subdivide only high or low 
curvature region. 
 
NOTE: The Subdivide operation can be applied an entire shell or locally selected 
region. 
 
Exercise: 
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(Being continued) 
1. Select Tool > Subdivide Shell menu, and select “helmet”. 
2. Click OK on dialog box with default option. 

   
Before subdivision    After subdivision 

 
Defeature 
The Defeature function removes selected region and to fill it using curvature-based 
method. The result is that you get a smooth polygonal surface on which features are 
eliminated. 
 
Exercise: 

1. Open “defeature.mdl” under “polygon_wb” folder. 
2. Select faces by rectangle mode as below. 

   
3. Click Tool > Defeature menu. 
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Volume Hole Filling 
This operation creates a new shell that its holes are filled by a volumetric hole filling 
method that constructs a reference voxel model having the geometry information of a 
shell and then fills its holes by extension of the boundary of holes. This new hole 
filling function allows you to fill holes which boundaries are messy and untidy. This 
operation creates a new polygonal shell while preserving an original shell. 
 
NOTE: You need to remove extra faces after applying the volume hole filling 
operation. The amount of extra faces depends on the number of iterations you select. 
 
Exercise: 

1. Open “volume_fillhole1.mdl” under “polygon_wb” folder. 
2. Check boundary edges by pressing E key. 
3. Click Tool > Fill Holes > Volume and pick a shell. 
4. Set Number of iteration to 30 and Resolution to 1. 

Note: Resolution is ratio to the average of vertex spacing. If the number is 
larger than 1, the edge length of a new shell will be larger than the average 
edge length of selected shell 

5. Check Except the Biggest Hole and Optimize Mesh options, then click OK. 

   
6. Try to apply Tool > Fill Holes > Surface to the same model above. 
7. Open “volume_fillhole2.mdl” under “polygon_wb” folder and repeat the above 

process. 
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Remesh 
A face of good quality means that the face is close to an equilateral triangle. The 
Remesh operation improves the quality of the faces as re-triangulating the faces of 
the polygonal model.  
This operation improves the surface of the polygonal model by changing the 
coordinates of existing vertices. Thus, the continuity of the curvature can be 
improved without adding new vertices, differently from the Subdivide operation. It 
there are marked edges or vertices, the preserve option window will pop up. Clicking 
Yes button allows the marked edges or vertices to be maintained as it is. 
 
NOTE: The Remesh operation can be applied on an entire shell or locally selected 
region. 
 
Exercise: 

1. Open “helmet_decimated.mdl” under “polygon_wb” folder. 
2. Apply Tool > Remesh > Global to the shell. 

   
Before remeshing    After remeshing 
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Transform 
Occasionally you will have data that is offset from the world origin or from the 
position you want it in. You may wish to reorient such data before working on it. 
You can rotate, translate or scale objects to reorient, reposition or resize them. 
You can also use Calc Principal Axis Transform option to ignore all the previous 
input and transform the object with respect to its principal axis. The object is so 
transformed that its centroid moves to the zero point and its bounding box has the 
minimum volume. The principal axis transform is useful to arrange the symmetric 
model. 
 
Exercise: 

(Being continued) 
1. Select Edit > Transform > Model, and click Calc Principal Axis Transform 

button. The amounts of rotation and translation are automatically generated. 
2. Click OK. 

     
 

Divide / Mirror 
The Divide operation lets you slice a point cloud or a polygonal model using a 
reference plane. During dividing the model, you can select Mirror option. The Mirror 
creates a duplicate of a sliced model and flips and joins the copy at a reference 
plane so that it faces in the opposite direction of the original. 
This is useful if you want to design or make changes to a symmetrical model. Thus, 
you can divide the model, make changes to one of the halves, then use the Mirror 
function to create and attach a reversed duplicate to the other side. The mirror option 
mirrors curves and surfaces attached to a polygon model when it is mirrored. 
 
Exercise 1: 

(Being continued) 
1. Select and delete vertices using Shift+V and Alt+V keys as shown below. 
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2. Fill two holes of inside and outside (as shown below left). 
3. Select Ref. Geometry > Create > Plane > Input Normal & Position menu, 

and select Add with default values. Click Close. 

        
4. Select Tool > Divide/Mirror menu, and pick the shell. 
5. Select Pick Ref. Plane on RMB menu, and pick the reference plane. 
6. Select Done on RMB menu. 
7. Check Mirror & merge upper shell option and Remove lower shell on 

dialog box, and click OK. 

      
 
The Mirror operation enables you mirror polygonal shell without dividing. This 
operation provides a quick way of creating symmetrical object by requiring that only 
half of an object be perfected. 
 
Exercise 2: 

1. Open “airbag.mdl” under “polygon_wb” folder. 
2. Click Select > Boundary Vertices menu. 
3. Click Ref. Geometry > Create > Plane > Fit Region menu. 
4. Click Tool > Divide / Mirror menu, and select a shell. 
5. Click Pick Ref. Plane on RMB menu, and select the plane. 
6. Click Done on RMB menu. 
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7. Select Mirror Only option, and click OK. 
8. Click Tool > Weld > Shells menu. 
9. Click OK with default tolerance. 

 

                       
                Half of a symmetrical object               Perfect object by Mirror and Weld 
 
Shrink 
Generally, the region near the boundary of scanned data may contain more 
measurement errors. Therefore, it is a good idea to remove boundary portions before 
starting the registration or merging process. The Shrink operation removes faces on 
the selected boundary as a specific depth. 
 
Exercise: 

1. Open “face.mdl” under the “polygon_wb” folder. 
2. Select Tool > Shrink Shell, and click the shell. 
3. Select a boundary and type in 5 depth, and then click OK. 

                   
Before shrinking                After shrinking 

 
Extend 
The Extend Region command extends the boundaries of selected region onto the 
desired plane or in the normal direction of a default reference plane with a given 
distance. 
 
Exercise: 
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1. Open “joystick.mdl” under the “polygon_wb” folder. 
2. Click Select > Boundary Faces menu. 
3. Click Tool > Extend Region menu, and uncheck Tangent Extension option 

on RMB menu. Select Pick Ref. Plane on RMB menu and pick a plane. Then 
click Done on RMB menu. Click OK with to Plane option. 

           
 
Weld 
When you import the surface patches with foreign file format and tessellate them, 
you will need to stitch their boundaries to convert them into a combined shell. 
The Weld operation converts multiple shells to a combined shell, and also stitches 
the gaps between the boundaries of shells. You can also remove the small gaps 
between vertices on the combined shell in case that the gaps are smaller than a 
specific tolerance. 
 
Exercise: 

1. Open “car.mdl” under the “polygon_wb” folder. 
2. Show boundaries by Information > Show Boundaries menu or hot key E. 
3. Select Tool > Weld > Shells menu, and click OK. Show boundaries again as 

shown below right. 

       
4. Zoom in a gap and measure the distance by Measure > Distance > 

Point/Point > Along Line menu as shown below left.  
5. Select Tool > Weld > One Shell menu, and type in 0.1 tolerance. Click OK. 
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Offset (Surface) 
The Offset operation creates a new polygonal shell that is offset from the original. 
Although the operation appears to expand or contract the faces, it actually defines a 
new offset faces, which is a specific distance from the original shell. 
 
Exercise: 

1. Open “offset.mdl” under “polygon_wb” folder. 
2. Click Tool > Offset > Surface menu, and select a shell. 
3. Select Forward option as Offset direction, and click Preview. 
4. Click OK. 

                         
Before offset                                    After offset 

 
Offset (Volume) 
The Volumetric Offset operation constructs an offset polygonal shell by allocating 
its geometry information and the offset amount to a reference voxel model. This 
offset method can solve the problem that the meshes in offset region are entangled 
each other. This operation creates a new polygonal shell while preserving an original 
shell. 
 
Exercise: 

1. Open “volume_offset.mdl” under the “polygon_wb” folder. 
2. Click Tool > Offset > Volume and pick a shell. 
3. Set Offset Amount to 0.5, Resolution to 1 and Offset Direction to 

Backward,  
Note: Resolution is ratio to the average of vertex spacing. If the number is 
larger than 1, the edge length of a new shell will be larger than the average 
edge length of selected shell 

4. Click OK with checking Optimize Mesh option. 
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Before offset                                       After offset 

5. Compare with the result by Tool > Offset > Surface. 
 
Trim Region 
You can freely cut the region of a shell by closed curves just as cutting a paper with 
a knife. If reference curves form a closed path, the inside region of the path is cut off 
and registered as a new shell. Otherwise, edges near the path are aligned along 
selected reference curves. 
The Trim Region operation cuts off the region surrounded by given reference curves. 
You can define the reference curves in the Curve workbench. 
 
Exercise: 

1. Open “helmet_trim.mdl” under the “polygon_wb” folder. 
2. You are going to do texture mapping as shown below left. You have to divide 

regions before mapping images. 
3. Click Tool > Trim Region menu, and select the shell. 
4. Select four curves in a counterclockwise direction as shown below right. 

         
5. Select Done on RMB menu. 
6. Click Yes to cut the inside region off. 
7. To change the color of a new shell, go to project window and select Change 

Material on RMB menu. Drag and drop yellow color on the new shell as 
shown below. 

8. Apply above process to side part like band using pre-defined curves. 
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Fit Edges To Curves 
You can rearrange the meshes which reside near curves so that the boundary edges 
of meshes could be coincident with the curves. This operation can be used for 
repairing the boundary edges of polygonal model or for reconstructing sharp edges. 
It also may rearrange edges for dividing polygonal model by regions which you want. 
 
Exercise: 

(Being continued) 
1. Click Tool > Fit Edges To Curves menu, and select the shell. 
2. Select four curves as shown below right. 

  
3. Select Done on RMB menu, and click No button to rearrange only faces 

crossing the selected curves. 

 
Before rearranging edges 
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After rearranging edges 

Split Edges 
The Split Edges operation splits faces to both sides along edges, which are 
connected to selected vertices. This operation automatically finds the edges 
consisting of a path by searching the shortest distances between the selected 
vertices. You have to select series of vertices so that they form a non-crossing path. 
 
Exercise: 

(Being continued) 
1. Click Tool > Split Edges > By Custom Path menu, and pick vertices in 

numerical order as below. 

 

 
2. Select Done on RMB menu. 
3. Push the hot key E to check the result. 
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4. Select Select > Flood Fill menu, and pick the inside of above closed path. 

Then the faces of the inside will be selected. 
5. Open again “helmet_trim.mdl” and try to apply Tool > Split Edges > By 

Curves operation. 
 
Tweaking Polygon 
Sometimes point clouds from scanners are too complex to polygonize easily. To 
solve this problem, you firstly have to do point sampling. In this case, the polygonal 
model can distort the original point cloud. The Fit Shell To Point Cloud operation lets 
you have a triangulated model close to the original model by re-fitting the polygon 
shell to the original point cloud.  
A polygonal model also can be distorted after editing polygonal meshes by smooth, 
decimation, and so on. The Fit Shell To Meshes operation lets you solve the problem 
by re-fitting the modified shell to the original polygon shell. 
You will generate watertight, smooth surfaces on a polygonal surface in Surface 
workbench. You also can smooth or deform these surface patches. After then, you 
can regenerate a modified polygon model by re-fitting the original polygon shell to 
the generated surfaces using the Fit Shell To Surfaces operation. So you can get 
more smooth shell or completely deformed shell. 
 
Exercise 1: Tweaking Polygon To Point Cloud 

1. Open “sole.mdl” under the “polygon_wb” folder. 
2. Apply Build > Triangulate > 3D operation to the point cloud, and check the 

result. 

       
3. Open the file again. Copy the shell by pushing Ctrl+C and Ctrl+V keys in 

order. 
4. Apply Build > Filter Redundancy operation to the copied shell three times. 
5. Apply Build > Triangulate > 3D to the filtered shell. 
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6. Go to the Polygon workbench. 
7. Apply Tool > Smooth > Shell to the triangulated shell without checking Move 

Boundary Vertices option. 
8. Fill all holes using Tool > Fill Holes > Surface operation as below left. 
9. Apply Tool > Subdivide Shell operation to the shell. 
10. Select Tool > Fit Shell To > Point Cloud menu, and then pick the copied 

shell and the original point cloud in order. The result is shown as below right. 

       
11. Repeat Smooth, Subdivide and Fit Shell To Point Cloud operations. 

 
12. Apply Tool > Subdivide Shell operation to the shell. 

 
Exercise 2: Tweaking Polygon To Polygon 

1. Open “harubang.mdl” under the “polygon_wb” folder. 
2. Copy the shell by pushing Ctrl+C and Ctrl+V keys in order. 
3. Apply Tool > Decimate > High Quality to the copied shell. Reduce to 20%. 
4. Apply Tool > Smooth > Shell to the shell without checking Move Boundary 

Vertices option. 
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      Original model   Modified model 

5. Check deviation between two shells by Measure > Shell/Shell Deviation 

menu. 

 
6. Apply Tool > Fit Shell To Meshes to the modified shell. 
7. Check deviation again. 

        
Exercise 3: Tweaking Polygon To Surface 

1. Open “helmet2.mdl” under the “polygon_wb” folder. 
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2. Render the pre-defined NURBS surface by pushing the hot key R. 
3. Click Tool > Fit Shell To > Surfaces menu. 
4. Select the surface, and click Done on RMB menu. 

              
       Rendered surface         Re-fitted polygonal surface 
 
Fit Boundary To Curves 
You can rearrange or clean the boundary meshes by curves. This operation can be 
used for repairing the boundary edges of a model that may have been introduced 
during the scanning process. 
 
Exercise: 

1. Open “wheel.mdl” under the “polygon_wb” folder. 
2. Push the hot key E to display boundary edges. 

 
3. Go to the Curve workbench. 
4. Click Curve > Create > Fit Boundary menu and select one of boundaries, 

and then click Done on RMB menu. 
5. Move the slide bar to the left as two steps and click OK. 
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6. Go to the Polygon workbench. 
7. Click Select > Vertices Around > Curves menu, and select the curve. 
8. Click Tool > Fit Boundary To Curves menu and select the curve, and then 

click Done on RMB menu. Click OK with a default value. 

   
9. Apply Fit Boundary To Curves to other boundaries. 

 
Fit Regions To Plane/Cylinder/Sphere 
You can fit polygons to a plane, cylinder or sphere, project them onto a primitive. 
Because the planes, cylinders and spheres created with these operations are 
mathematically perfect, this feature helps you create accurate mechanical shapes. 
This is very useful in cleaning up planar, cylindrical or spherical regions of a model 
containing noise or other imperfections. When you select a region of the model and 
apply the operation, the application assesses the selection, finds the best possible 
plane, cylinder or sphere within the selection and fits all the polygons to it. 
You can also define a reference plane or sphere, and the operation fits the selected 
polygons to that plane or sphere. 
 
Exercise: 

1. Open “handle.mdl” under the “polygon_wb” folder. 
2. Select Ref. Geometry > Create > Plane > Pick Points menu, and pick three 

or more points as below left. Select Done on RMB menu. 

     
3. Push Select Visible Faces Only icon on the Select Toolbar. 
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4. Select Fit Regions To > Plane menu. Click Select Region on RMB menu, 
and select faces as below left. Click Done on RMB menu. 

5. Select Pick Ref. Plane on RMB menu, and pick the pre-defined plane. 
6. Perform Do Plane Fitting on RMB menu, and push the hot key Shift+N. 

       
7. Toggle off Select Visible Faces Only icon and on Select Faces Through on 

the Select Toolbar. 
8. Select Fit Regions To > Cylinder menu. Click Select Region on RMB menu, 

and select faces as below left. Click Done on RMB menu. 
9. Select Pick Ref. Vector on RMB menu, and pick the pre-defined vector. 
10. Perform Do Cylinder Fitting on RMB menu, and push the hot key Shift+N. 

         
11. Select faces as below left. 
12. Select Fit Regions To > Sphere menu. 
13. Perform Do Sphere Fitting on RMB menu, and push the hot key Shift+N. 

           
 
Deform Polygon 
The Deform Polygon operation deforms the polygonal faces in real time by curve 
deformation, by free-form deformation or by painting. The Deform By Paint 
operation provides you an option, Set Weight Curve, which is a curve-based 
blending tool, enabling you to assign the weight factor to each position of the 
paintbrush. 
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NOTE: On the dialog box, the horizontal axis of the graph represents the position 
from the center of paintbrush; the vertical axis represents the user-defined weight 
factor. You can assign the weight factor to each position of paintbrush 
elaborately. 

 
Exercise:  

1. Open “foot.mdl” under the “polygon_wb” folder. 
2. Click Select > Faces Around > Curves menu, and click Select > Enlarge > 

One Depth menu.  
3. Click Tool > Deform By > Curve menu, and select a curve. 
4. Resize yellow circle by mouse drag while holding Shift key as below. 

 
5. Deform curve by moving its control point as shown below left. 
6. Click Done on RMB menu. 
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Deform curve                     After deform by curve 

7. Click Tool > Deform By > Paint menu. 
8. Resize brush by mouse drag to the left or right while holding Shift key as 

below left. 
9. Move brush on faces as painting, and then click Done on RMB menu. 

    
                                    Resize brush                           Deform by paint 

(Tip: Move brush while pushing Ctrl key to impress the region down) 
10. Select faces as below left. 
11. Click Tool > Deform By > FFD menu, and select a shell. 
12. Select four nodes to be moved by paint brush while holding Shift key as 

below right. 

                 
Selecting faces                                Selecting nodes 

13. Click Use Manipulator on RMB menu, and pick one of the selected nodes. 
14. Move mouse to the right while holding down LMB on the green arrow. 
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Using manipulator                            Deform by FFD 

15. Click Save button to reuse the table of control points. 
 

Engrave Text 
The Engrave Text operation lets you engrave or emboss text on a polygonal object 
using most fonts on Windows systems including TrueType fonts. To engrave text on 
a polygonal surface a NURBS patch is needed, so a surface patch should be made 
before engraving. The initial orientation of the text will be parallel to the U-direction of 
the surface and vertical to the V-direction. The surface may be attached or be not 
attached to a polygonal object. In case of unattached surface, engraving generates a 
new shell in text shape. If the engraving height is a negative value, it impresses text 
on the polygon, while a positive value embosses the text. 
 
NOTE: To obtain a high quality engraving shape, the region should have a high 
density of polygon faces.  To increase the number of faces in the region of the shell 
where the engraving will be, select the area and then use Tool > Subdivide Region 
before applying the engrave operation. 
If English and other language are both engraved at the same time, only the English 
text is normally applied in the correct font. 
 
Exercise: 

1. Open “golfclub.mdl” under “polygon_wb” folder. 
2. Click Tool > Engrave > Engrave Text menu and select a surface. 
3. Enter the desired text you want to engrave in the Text box. 
4. Select a font type you want to use after pushing the Font button. 
5. If necessary, use the Rotate or Flip button to adjust the text orientation, also 

move the slide bars of U-Scale and V-Scale items. 
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6. Set Engraving Height as 1. 
NOTE: A negative value impresses text on the polygon, while a positive value 
embosses the text. 
7. Turn on the Trim the Selected Surface option, and click OK button. 

 
8. Hide the shell and the largest surface, and render the trimmed surfaces by 

pushing the hot key R. 

 
9. The below is examples for Chinese and Korean characters. 

     
 
Engrave Image 
The Engrave Image operation lets you engrave or emboss images on a polygonal 
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object using a 2D image. To engrave an image on a polygonal surface a NURBS 
patch is needed, so a surface patch should be made before engraving. The initial 
orientation of the 2D image will be parallel to the U-direction of the surface and 
vertical to the V-direction. The surface can be does not need to be attached (but it 
can be) to the polygon mesh. If the surface is not attached to the polygon mesh, a 
new shell will be created when engraving. 
 
NOTE: To obtain a high quality engraving shape, the region should have a high 
density of polygon faces.  To increase the number of faces in the region of the shell 
where the engraving will be, select the area and then use Tool > Subdivide Region 
before applying the engrave operation. 
 
Exercise: 

1. Open “coin.mdl” under “polygon_wb” folder. 
2. Click Tool > Engrave > Engrave Image menu and select a surface on the 

coin. 
3. Click the button in the right side of the File Name box and open “engrave.jpg” 

file from the “polygon_wb” folder. 
NOTE: The image files which can be opened are bmp, cgm, cmp, dwg, dxf, 
eps, jpg, pcx, png, psd, tga, tif, wmf, and xbm. The selected image is 
displayed as a gray scale. 
4. Click twice the Rotate button to adjust the image orientation and move the 

slide bars of U-Scale and V-Scale items. 

    
5. Set Max. Height as 0.5 and Min. Height as 0, and then press the Blending 

Curve button. To adjust the height balance of the gray image, drag control 
points on a curve as shown below left or open “engrave.rbc” file from the 
“polygon_wb” folder after pressing the Load button. 

NOTE: In this example, white color comes out from the surface with a max. 
height in its normal direction. But the default is that black color comes out and 
white color comes into the surface in the inverse direction of its normal. To back 
to the default state, click the Reset button. 
6. Push the Preview button and check the height of each pixel by rotating the 

object. 
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7. Turn on the Smooth option, and click OK. 

   
 

Polygon Template 
The Polygon Template operation lets you reuse the polygon mesh structure as a 
template. Thus, you will be able to retrieve the polygon structure of one template 
model and apply it to a different model. 
The operation automatically aligns the template model to another reference model 
and automatically generates anchor points. Auto Anchor automatically associates 
boundary vertices of a template with the closest points on the reference model. 
Although the associated points may be the closest points, they may not be where 
you want them. To remedy this, you can add and reposition anchor points. 
You can move nodes of the template to the positions where you want on the 
reference model using deformation and translation rule of nodes. Finally, you can 
obtain a new template model for the reference model by relaxing template. 
If you want to apply the polygon template operation to the part of shell, you have to 
select a region in the template shell in advance. 
This operation can be applied to selected regions or the entire shell. By selecting a 
region, its boundary becomes fixed and its control points can be manipulated to 
match the reference shell. The number of control points that are moved along with 
the region boundary can be controlled using the Blending Depth option on the RMB 
menu. The operation provides you an option, Set Blending Curve, which is a curve-
based blending tool, enabling you to adjust the position of vertices in the selected 
region of a template shell to a reference shell. 
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NOTE: On the dialog box, the horizontal axis of the graph represents the user-
defined depth; the vertical axis represents the position of a template shell (0) and 
a reference shell (1). You can adjust the selected region in the template shell to 
the reference shell with the position of each depth. “Depth 0” means the 
boundary of the selected region. 

- The following is an example that the selected region of a plane is applied to a 
sphere. 

 
Plane (Template:0) & Sphere (Reference:1) 

 
Exercise: 

1. Open “template.mdl” under the “polygon_wb” folder. 
2. Select Tool > Polygon Template menu, and pick the “template” shell and the 

“reference” shells in order. Click Yes button to align two shells. If necessary, 
click Depth Cueing icon on the View toolbar to distinguish easily nodes in 
front from nodes at the back as shown below right. 
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3. Zoom in mouth area, and uncheck Pause and click Move Nodes on RMB 

menu. 
4. Select nodes around mouth to be deformed by dragging mouse with holding 

Shift+LMB as below left (white points). Continuously, select nodes to be 
translated by dragging mouse with Shift+RMB as below right (yellow points). 

     
5. Deselect the selected nodes which you didn’t intend by dragging LMB with 

holding Ctrl key. 
6. Drag mouse pointer on an arbitrary node among selected ones with holding 

down LMB so that they position around mouth area of the reference shell. 
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7. Change viewpoint as below left, and move nodes as below right.  

       
8. Deselect all selected nodes by dragging LMB while holding down the Ctrl key. 
9. Apply above process to nose and eyes area. 
10. Click Auto Anchor on RMB menu, and click Move Anchor and then move 

the anchors to the position, which you want around eye as shown below. You 
can also add or delete anchors. 

      
Before moving anchors     After moving anchors 

11. Click Relax Template on RMB menu, and push Esc key. You will obtain a 
new template model (as shown below right). 

   
After relaxing      New template model 

(NOTE: You may skip the above steps from 3 to 10 for similar shape models) 
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Find Medial Axis Points 
The Find Medial Axis Points operation creates a new point set by arranging vertices 
of polygonal shell around its medial axis. This operation moves all points on 
polygonal surface to a center axis or a midplane. 
 
Exercise: 

1. Open “pipe.mdl” under “polygon_wb” folder. 
2. Click Tool > Find Medial Axis Points menu, and select a shell. 
3. Hide “pipe” shell in the project tree window. 

                         
Pipe shape object                  Medial Axis Transformation 

 
Polygon Morphing 
The Polygon Morphing functionality enables you to transform a polygonal model to 
another polygonal model and to view and save interim morphs on the way to the 
transformation. Pixform Pro employs landmark based volume morphing, so you have 
to indicate some landmarks on each model. This operation supports the multiple 
window system for easy landmark selection. 
 
Exercise 1: 

1. Open “face_morphing.mdl” under “polygon_wb” folder. 
(Reference points were predefined in each shell by Ref. Geometry > Create > 
Point > Pick Point menu and renamed in project window) 

2. Push RMB on the string “Points” in project window and click Show/Hide 
Name on pupup menu. 
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(NOTE: The name of points at the same position in each shell should be same) 
3. Click Tool > Polygon Morphing menu, and select “template” and then 

“reference”.  
4. Click Load button in dialog box and open “landmark.txt” file. 
5. Click Scan Ref. Points button, then IDs of two shells are automatically 

scanned. 
6. Try to move the slide bar in Interpolation Ratio to the right. Click Add Shell 

button at ratio 0.3. Move the slide bar at ratio 0.6 and move the slide bar of 
Effective Intensity to the left as one step. 

7. Click Add Shell, and then click Cancel button to preserve the original 
template shell. 

 
                            Template(0.0)     at (0.3)        at (0.6)     Reference(1.0) 
Exercise 2: 

1. Open “dental.mdl” under “Pixform Pro/Sample” folder. 
2. Create about 40 reference points on each shell, and rename them as a same 

name for a corresponding point. 
3. Repeat the above exercise 1. 

 
 
Thicken 
Pixform Pro’s thickening operation converts an open shell into a volume shell with a 
constant thickness, and also it converts a volume shell into a shell type model with a 
constant thickness. This operation allows you to control the direction in which the 
model’s surface is thickened.  
 
NOTE: This operation may introduce self-intersections, which are undesirable in 
some cases.  
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Exercise: 
1. Open “golf_head.mdl” under “polygon _wb” folder. 
2. Apply Tool > Make Volume > Thicken. 
3. Type in 1 thickness on the dialog box, and select Preview with Backward 

offset for inner direction as below right. 

   
Golf head before thickening      When preview 

4. Select OK, and perform Measure > Cross Section > Model menu for 
checking the volume. Try to move position bar after checking Z axis and Hide 
Front option. 

             
After thickening Cross section 

5. Open “wheel_cover.mdl”, and repeat above process. 

                      
 Wheel cover of car   After thickening 
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Extrude to Plane 
Similar to the thickening operation, extrusion operation also converts open shells that 
do not bound volume into closed solid models that do. The main differences between 
the two operations are the thickness of volume and the existence of open boundary. 
By this operation, volume shells don’t have a constant thickness because boundary 
edges of open shell are extruded to a specific plane. 
This operation allows two more holes or boundaries to extrude to the specific plane 
called the projection plane. It has a Tangent Extrusion option on the RMB menu, 
which extrudes the shell tangent to the boundary, in addition to the standard 
extrusion, which extracts directly to the plane. 
 
Exercise 1: 

1. Open “golf_head.mdl” again. 
2. Apply Tool > Make Volume > Extrude to Plane. 
3. Select Pause on RMB menu, and change view as below right. 

      
4. Separate the projection plane from object as small distance by 

CTRL+SHIFT+LMB(up/down direction) as below left, and then click Done on 
RMB menu. 

     
5. Open “tap.mdl”, and repeat above process. 
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Tap before thickening      After thickening 

 
Exercise 2: 

1. Open “joystick.mdl” under “polygon _wb” folder. 
2. Push E key to show boundaries. 
3. Click Tool > Make Volume > Extrude to Plane menu, and select a shell. 
4. Click Pick Ref. Plane on RMB menu, and select the plane. 
5. Click Done on RMB menu. 

 

         
Shell without thickness                          Solid body by Extrude 

 

Boolean Operations 
Boolean operations let you add a solid to or subtract a solid from another solid. 
Pixform Pro provides you union, intersection, and difference as Boolean operation 
for polygon models. 
 
Exercise: 

1. Open “boolean.mdl” under “polygon _wb” folder. 
2. Apply Information > Check Interference to two shells for displaying the 

interference line as shown below left. 
3. Select Edit > Enable Undo menu for activating undo command. 
4. Apply Tool > Boolean > Union. 
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      Check interference                                  Union 

5. Select Edit > Undo menu to return to the previous step. 
6. Apply Tool > Boolean > Intersection. 
7. Select Edit > Undo menu to return to the previous step. 
8. Apply Tool > Boolean > Difference, and select “venus” and “sphere” in turn. 

   
   Intersection          Difference 

 
Work Volume 
The accuracy and efficiency of rapid prototyping process depend on how the object 
is positioned in the work volume. The user’s choice of part orientation in the building 
chamber will have an impact on build time, part resolution, and surface finish. 
Obviously, minimizing the height of the geometry will reduce the number of layers 
required, thereby decreasing build time.  
With RP workbench, you can define a work volume and align multiple objects onto it. 
 
Exercise: 

1. Open “work_volume.mdl” under “polygon _wb” folder. 
2. Apply Tool > Work Volume > Create, type in 500 each blank, and select OK. 

Turn off the perspective view icon on the View toolbar to disable it. 
3. Apply Tool > Work Volume > Align > Min Height to “venus” shell. 
4. Apply Tool > Work Volume > Align > Face to “hand” shell, and pick a face 

on the bottom of arm. 
5. Apply Tool > Work Volume > Align > 3 Points to “pelvis” shell, and pick 

three points of leg bottom as below right. 
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Export Slices 
Slicing will proceed along the slice axis, z-axis. The height of each step is the layer 
thickness used in that portion of the part. A support structure may be required, 
depending on the part’s orientation. Finally, you may write the slicing data to several 
rapid prototyping file formats. 
 
Exercise: 

(Being continued) 
1. Apply Tool > Find Overhang Region to “hand” shell to find the area required 

the support structure. 
2. Select “hand”, and click Done on RMB menu. 
3. Type in 30 degree, and select OK. 
4. Apply Tool > Export Slices to “hand” shell. 
5. Type in 5 Layer Thickness, and click Preview. 
6. Click Export button, and save the slicing data to a specific data format. 
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Finding overhang region                                      Slices 

 
Detect Collision 
The Detect Collision operation is On/Off toggle menu for displaying the interference 
regions when a shell moves into another shells dynamically by Edit  > Transform  > 
Shell Trackball. 
 
Exercise: 

1. Open “teeth_frame.mdl” under “polygon _wb” folder. 
2. Click Edit > Transform > Detect Collision menu to toggle ON. 
3. Push Ctrl+T key, and select a shell named “frame”. 
4. Try to move the shell in the Z (blue arrow) direction and check the detect 

region. 
5. Push ESC key. 

       
Before and After applying Detect Collision 

 
Restrict Collision 
The Restrict Collision operation is On/Off toggle menu for restricting the penetration 
between shells when a shell moves to another shells dynamically by Edit  > 
Transform  > Shell Trackball. 
 
Exercise: 
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1. Open again “teeth_frame.mdl” under “polygon _wb” folder. 
2. Click Edit > Transform > Restrict Collision menu to toggle ON. 
3. Push Ctrl+T key, and select a shell named “frame”. 
4. Try to move the shell in the Z (blue arrow) direction and check whether 

“frame” penetrates through “base”. 
5. Push ESC key. 

              
Before applying Shell Trackball             Effect of Restrict Collision 

 
Transformation by Ref. Geometry 
Reference geometries are point, vector, plane, circle, sphere, cylinder, cone, box, 
torus and coordinate which are introduced for various purposes such as dividing, 
making volume, slicing, section viewing, measuring, transformation, alignment, etc. 
Especially using these reference geometries, it is useful for aligning two different 
models which come from different coordinate system. Reference geometries are 
automatically attached to a shell if they are created by its entities. If necessary, you 
can break the connection with a shell. 
 
Exercise: 

1. Open “ref_geometry.mdl” under “polygon_wb” folder. 
2. Click File > Preferences menu and go to Display Options tab, and then 

select the Vertex snap check box in the Picking option. 
3. Click Ref. Geometry > Create > Circle > Pick Points menu, and pick three 

points on the boundary of hole as below. And then click Done on RMB menu. 
4. Click Ref. Geometry > Create > Coordinate > Pick Origin & Input Rotation 

menu, select Ref. Point on RMB menu, and pick the center point of the circle. 
And then click OK button in the dialog box. 

      
5. Apply a reference circle and a coordinate to a cylinder block. 
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6. Click Ref. Geometry > Transform > Coordinate > Align Coordinate menu, 

and select the coordinate of cylindrical block and then the coordinate on the 
hole. Click OK in the dialog box. 

 
7. Click Ref. Geometry > Create > Coordinate > Pick Origin & X, Y Direction 

menu, and pick corner points of a block1 in numerical order as below. 

    
8. Click Ref. Geometry > Create > Coordinate > Pick Origin & X, Y Direction 

menu, and pick corner points of a block2 in numerical order as below. 

          
9. Click Ref. Geometry > Transform > Coordinate > Align Coordinate menu, 

and select the coordinate of a block2 and then the coordinate of a block1. 
Click OK in the dialog box. 

10. Push F6 key to check the assembly status. 
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7.  Curve Workbench 
 
The surface creation process begins by laying down curves directly on the point 
cloud or the polygonal model to define the different surfaces to be created. You can 
define the layout of surfaces on your model by creating a network of curves that 
define the different surfaces. Each surface "patch" must be defined by two or more 
boundaries. 
 
There are two kinds of curves in the workspace: One is “Shell curve” that is 
automatically connected to a shell when it is created and all editing operation can be 
applied. Another is “Space curve” that is not connected to any shell and several 
operations like deformation cannot be applied. They may be introduced by curve 
template. 
 
There is another operation that can significantly speed up the surfacing process by 
eliminating many of the tasks involved in preparing a model for the NURBS surface. 
It is curve template. The Template operation allows you to save the curve network 
from one model and apply it to another model. 
 
The typical work process is as follows: 

1. Generate feature curves and boundary curves 
2. Make curve network and optimize it using editing tools 
3. Generate loops for surfacing 
4. Create a template for a special purpose 

 
NOTE: If there are two or more shells in the workspace, you must activate a shell by 

selecting it in the project window before creating curves because most curve 
operations are applied to the active shell. 

 
NOTE: In case both end points of a curve can be distorted, check out the vertex 

snap on the Display Options tab of File > Preferences. 
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Feature curve 
Feature curve speeds up the process of creating a curve network, a necessary step 
in surfacing. You can reduce the time it takes to construct a curve network for your 
model using the feature extraction and automated curve creation tool. 
If an object has more 100,000 triangles, it will take long time to find feature curves. In 
this case, you have to duplicate it and reduce to less 50,000 triangles, and then find 
feature curves, attach the curves to original shell and delete the copied shell. 
Additionally use an option, Quick Mode, a faster but less accurate curve generation 
method (useful for models with more obvious features). There is also an option on 
the RMB menu, Pick Radius Points, which allows you to capture the radius of a 
rounded region by picking points, and enters that information for feature curve 
generation automatically. 
 
Exercise: 

1. Open “shoe_last.mdl” under the “curve_wb” folder. 
2. Click Curve > Create > Feature Curves menu and pick the shell. 
3. Click Pick Radius Points on RMB menu, and pick two points on each 

rounded region as below. 

 
(Tip: A user can measure approximately the radius of rounding area by Measure 
> Radius > Rounded Area Radius) 
4. Click Done on RMB menu. Then feature radius is automatically inserted into 

the dialog box. 
(Tip: A user can type in a specific radius manually by clicking New icon on the 
dialog box) 
5. Check Use Shell Curvature option and click Preview button. 
6. Select Accept Curve on RMB menu, and pick a curve as shown below. 
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7. Click OK and save the model as a different file name. 
8. Open “cam.mdl”, and apply Feature curve operation to the shell. 
9. Type in 10 radius, and use all options. 
10. Construct sharp edges using Tool > Fit Edges To Curves operation in the 

Polygon workbench. 

    
 
Slice curve 
The Slice curve operation allows you to have section curves of the polygonal model. 
You can indicate the number of slices or the width of slices to be created. You can 
also slice the shell by a reference coordinate you defined. 
 
Exercise: 

1. Open the shoe model saved in the feature curve process above. 
2. Select Curve > Create > Slice menu, and pick the shell. 
3. Select X-axis, type in 3 number of slice, and position two reference planes as 

shown below. And then click Preview. 

 
4. Click Slice button. 
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Boundary curve 
The Boundary curve is automatically generated on boundary edges of the polygonal 
model in case it is not closed volume shell. You can trim the boundary by picking 
trimming points during the creation of the boundary curves. In that case, you must 
pick points in the counterclockwise direction for outside boundary or in the clockwise 
direction for the inside hole.  
 
Exercise: 

(Being continued) 
1. Select Curve > Create > Boundary Fit menu, click OK with default Fitting 

Parameter. 
2. Pick 4 trimming points around the slice curve in the clockwise direction as 

shown below, and click OK on RMB menu. 

 
 

Interpolation curve 
The Interpolate curve is a freeform curve with a set of interpolation points. The 
Interpolate operation is the most general tool to create curves manually. By this 
operation, you can fit a curve on the polygonal surface or create a curve passing the 
interpolation points. You can change viewpoint during picking interpolation points. 
 
Exercise: 

(Being continued) 
1. Select Curve > Create > Interpolate menu, click Start on RMB menu. 
2. Move mouse pointer closely to the end point of the pre-defined feature curve. 
3. Pick the point when it becomes red color, and another points as show below. 
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4. Select End > Generate Intermediate Points on RMB menu. 

 

Projection curve 
There are five kinds of projection curves, they are: Polyline; Rectangle; Circle; 
Ellipse; and Grid. You cannot change the viewpoint during the picking of projection 
points. 
 
Polyline: multiple connected curves of line type 

Rectangle: rectangular curves 

Circle: circular curves 

Ellipse: elliptical curves 

Grid: connected curves of grid type 

         
  Polyline    Rectangle    Circle 

        
        Ellipse          Grid 
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Match 
The Match operation matches two curves so that their end points should be 
coincident or tangent to each other. The first selected curve is matched to the 
second selected curve. 
 
Exercise: 

(Being continued) 
1. Select Curve > Tool > Match menu. 

 
2. Pick two curves in turn. 

 
3. Check Position Continuity, and click OK. If fail, increase Matching 

Tolerance. 
4. Repeat for other curve that its end points are positioned closely. 

 

Deform 
The Curve Deform operation deforms the geometry of a curve by translation of its 
control points. Curves can be smoothened by this operation. 
You can deform curves not only on the polygonal surface but also by space. If 
curves are disconnected from a polygon shell, “Move on Polygon” option is 
automatically turned off and curves are deformed without relation to the shell. So if 
you want to deform curves on polygon, firstly connect curves to the shell using 
Attach to Shell functionality. 
You can deform curves continuously without quitting the operation. 
 
Exercise: 

(Being continued) 
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1. Select Curve > Edit > Deform menu, and pick a curve below. 

 
2. Define the region of control points to be deformed with a yellow circle by 

mouse drag to the left or right direction while holding down LMB and Shift key. 
3. Drag mouse pointer on an arbitrary control point among selected ones while 

holding down LMB. 

     
 
Trim 
The Trim operation trims curves into more than two curves. 
The Curve/Curve operation breaks two overlapping curves into four separate curves 
that share a break at the intersection. The Curve/Surface operation breaks a curve at 
its intersection points with a surface patch. The Pick Point operation creates a break 
in a curve at a selected point. This is useful for making T-joints. The N-division 
operation breaks a curve into N curves such that all the trimmed curves have same 
length with each other. The Global operation breaks selected curves globally at their 
intersections. 
 
Exercise: 

(Being continued) 
1. Select Curve > Trim > Pick Point menu, and select a curve and a point as 

below. 
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2. Select Curve > Trim > Global menu, and select all curves by mouse drag. 

Then click Done on RMB menu. 

    
 

Merge 
The Merge operation connects two curves that share a common end point 
These two curves should be matched at the end point. 
 
Exercise: 

(Being continued) 
1. Apply Curve > Tool > Merge operation to four divided curves. 

 
 
Silhouette Curve 
The silhouette curve is a set of visual edges where the model stops and the 
background begins on the current view. This command provides you two kinds of 
silhouette curves, visible silhouette and projected silhouette. Like mold’s parting line, 
they are used to cut the model in two along the silhouette. 
 
Exercise: 

1. Open “shoe_last.mdl” under “curve_wb” folder. 
2. Set the viewpoint as below by pressing Alt+6 key. 
3. Click Ref. Geometry > Create > Plane > Pick Point with Viewing Direction 

and pick a point at the center of shoe. 
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4. Click Curve > Create > Silhouette > From Shell and pick a shell then select 

a ref. plane. 
5. Click OK with Generated Projected Silhouette Curves option. 
6. Repeat the above process with Generate Visible Silhouette Curves option. 

   
                 Projected Silhouette Curve                       Visible Silhouette Curve 

 
Fit Points 
The Fit Points operation creates a curve fit to the path of curve typed point cloud. 
 
Exercise: 

1. Open “pipe.mdl” under “polygon_wb” folder. 
2. Click Tool > Find Medial Axis Points menu, and select “pipe.” 
3. Hide “pipe” and select “Medial Axis Shell” in the project tree window. 
4. Select vertices in both ends as below, and push Alt+V key to delete them. 

 
5. Go to Scan workbench. 
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6. Click Build > Filter Redundancy menu, and select “Medial Axis Shell”. 
7. Click OK with default value. 
8. Repeat once more the above step 6 and 7. 
9. Go to Curve workbench. 
10. Click Curve > Create > Fit Points menu, and select “Medial Axis Shell”. 
11. Click OK with default value. 

        
Curved point cloud Curve fit to points 

 
Mirror 
The Curve Mirror operation allows you to mirror curves against a center plane. The 
mirrored curves are space curves and are not attached to the shell. This operation 
enables you to save the modeling time and effort to generate a curve network for a 
symmetrical object. 
 
Exercise: 

1. Open “mirror.mdl” under “curve_wb” folder. 
2. Click Curve > Create > Mirror and select all curves except ones on the 

center plane as below left. And then click Done on RMB menu. 
3. Select a center plane. Push F6 key for transparent viewing. 
4. Click Curve > Tool > Attach to Shell and select all mirrored curves as below 

right, and then select the shell. 
5. Click Curve > Tool > Rebuild and select all mirrored curves, and click Done 

on RMB menu. Check Use existing point numbers option and click OK. 
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Convert To Shell 
The Convert To Shell operation converts the selected curves into a point cloud 
through the tessellation process. The new shell may consist of uniform or non-
uniform point clouds, or it can be constructed with only the end points of the curves. 
 
Exercise: 

1. Open “torso.mdl” under “curve_wb” folder. 
2. Click Curve > Tool > Convert To Shell and select all curves, and click Done 

on RMB menu. 
3. Check Use Curve Node Point Only option on the dialog box and click OK. 
4. Hide the shell “torso” in project window and push 4 key to hide all curves. 
5. Click File > Preferences and select Display Options tab, and set Point 

Drawing Size to 5 and click OK. 

                      
 
Merge Node 
The Merge Node operation enables all nodes of curves to connect each other and 
matches all curves so that their end point should be coincident. The advantage is to 
reduce the drawing errors within tolerance when you create curves manually. 
 
Exercise: 

1. Open “merge_node.mdl” under “curve_wb” folder. 
2. Click Edit > Enable Undo to activate the undo function. 
3. Click Curve > Edit > Deform menu, and select a curve as shown below left. 
4. Try to move the end point of curve as shown below right. 

 
NOTE: Two yellow ones are coincident at the end of the selected curve, but three 
blue ones are disconnected to it. 
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5. Push ESC key and click Edit > Undo to return to the previous state. 
6. Click Curve > Tool > Merge Nodes menu. 
7. Type in 0.1 as tolerance, and click OK. 
8. Click Curve > Edit > Deform menu, and select the curve again. 
9. Repeat the above step 4. 

 
                                Effect of curve deformation after merging nodes 
 
Template 
The Curve Template operation can significantly speed up the surfacing process by 
eliminating many of the tasks involved in preparing a model for the NURBS surface. 
The Template operation allows you to save the curve network from one model and 
apply it to another model. That is, if you have the Templates functionality and an 
existing set of curves for a similar model, you may apply those same curves to your 
model. 
 
NOTE: If you create a template with loops, you can’t delete the loops until the 

template is deleted. 
 
Exercise: 

1. Open “template.mdl” under the “curve_wb” folder. 
2. Select Template > Create menu, and select all curves. 
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3. Select Template > Tool > Detach from shell menu, and pick the template. 

 
4. Select Template > Tool > Attach to shell menu, and pick the template, then 

“man_face” shell. 
5. Select Template > Tool > Transform menu, and pick the template. 
6. Approximately transform the template to the similar position of the man using 

manipulator. 

          
7. Select Template > Projector > Auto Generation menu, and pick the 

template. 
8. Zoom in around eye. 
9. Select Template > Projector > Add/Edit menu, and pick the template. 
10. Click Edit Projector on RMB menu, and move nodes to the proper position. 
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11. Click Done on RMB menu. 
12. Select Template > Apply menu, and pick the template. 
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8.  Surface Workbench 
 
When you have created and edited the curve network or loops, you are then ready to 
generate NURBS surfaces. Pixform Pro allows you to generate a watertight, smooth 
surface.  
 
There are two methods to create NURBS surface: Automatic and Manual. Automatic 
surface generation doesn’t need tedious curve drawing, so helps you speed up your 
surfacing work. Manual surface generation can completely maintain the flow line of 
the original polygon surface though it takes much time than auto surfacing. Manual 
surfacing branches to work by curves or by loops. Manual surfacing by loops is 
closer to the auto surfacing to some extent. Also manual surfacing allows you to 
create trimmed NURBS surface. 
 
Surfacing work using loop is faster than the same work using only curves. Loop is a 
set of curves that form a closed loop topology. If a surface is created with a loop, the 
loop contains the connection with the surface, the number of control points of it, and 
surface type. 
 
Pixform Pro provides various generic surface creation tools such as n-boundary, 
blend, loft, sweep, extrude, revolution, offset, planar, spherical and cylindrical.  
Once the NURBS surface is generated, you can edit it by deforming, trimming, 
smoothing, or editing control points, and improving surface continuity. 
You can evaluate the surface by plotting deviation between surface and original 
polygon, curvature plotting and environment mapping. You can also generate 
displacement maps of the deviation between the original polygonal surface and the 
NURBS surface. 
 
There are two types of surface: Untrimmed surface and Trimmed surface. The 
former is for a patch having 4 boundary curves and the latter is for patches having 2, 
3, or more than 5 boundary curves. You can control the shape of the surface by 
using the number of control points in the U and V directions. In the Untrimmed 
surface, the U direction is defined by a curve that is first picked. In the Trimmed 
surface, the U direction is automatically determined by algorithm. You can assign the 
number of total control points instead of U and V control points. 
 
In the workspace, there are two kinds of surfaces: One is “Shell surface” that is 
automatically connected to a shell when it is created and all surface operations are 
available. Another is “Space surface” that is not connected to any shell and 
operations related to a shell are not available. 
 
The typical work process is as follows: 

1. Fit NURBS surface to polygonal model 
2. Edit NURBS surface patches 
3. Analyze the surface 
4. Improve the continuity and smoothness 
5. Export to the downstream application 
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Loop 
Loop is a set of curves that form a closed loop topology. If a surface is created with a 
loop, the loop contains the connection with the surface, the number of control points 
of it, and surface type. 
For creating a loop, pick more than two curves of the closed loop, which will become 
the boundaries of a surface in the clockwise (CW) or counterclockwise (CCW) 
direction. But the direction of a seed loop, which is used to automatically find loops, 
must be CCW. The direction of a loop is same as the direction of the first selected 
curve. 
The Synchronize operation automatically synchronizes the direction and start curve 
of loops to match the number of control point in U, V directions. 
 
NOTE: If you create loops with curves, you can’t delete the curves until the loops are 

deleted. 
 
Exercise: 

1. Open “shoe_loop.mdl” under the “surface_wb” folder. 
2. Make sure to show direction of curves by Curve > Options > Show 

Direction as shown below left. 
3. Select Loop > Create menu, pick four curves in CW or CCW direction as 

shown below right. 
NOTE: The direction of a first selected curve determines the direction of loop 
which should be CCW. 
4. Click Quit on RMB menu. 

    
5. Select Loop > Find Loops menu, and select all curves. Click Done on RMB 

menu. 

 
6. Select a seed loop made in the above step 3. 
7. Check Use outer loop option, and click OK. Click Loop > Delete and select 

a loop around the hole as below. Click OK. 
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8. Synchronize loops by Loop > Synchronize operation. 

 
Polygon Fit 
The Polygon Fit operation fits the surface to polygon with the curves or loops, which 
were drawn on the polygon model. You can create more than two surfaces at once 
by applying the same parameters to all surfaces. 
 
Exercise 1: By Curves 

1. Open “shoe_curve.mdl” under the “surface_wb” folder. 
2. Select Surface > Create > Polygon Fit > By Curves menu, and pick four 

curves as shown below in the counterclockwise direction. Click Add Loop on 
RMB menu. 

  
3. Select another four curves, and click Add Loop on RMB menu. Click Done 

on RMB menu. 

  
4. Click Preview button with default values. 
5. Change No. of U Control Points to 7, and click Preview again. 

  
  (U, V)=(10 X 10) C.P.   (U, V)=(7 X 10) C.P. 

6. Click OK. 
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7. Now, select curves on the bottom as shown below, click Add Loop and Done 
on RMB menu. Set No. of Total Control Points to 300 and change Surface 
Type to Trimmed, and click Preview. 

   
8. Click OK. 

 
Exercise 2: By Loops 

(Being continued) 
1. Hide all curves and show all loops in project window. 
2. Select Surface > Create > Polygon Fit > By Loops menu, and select all 

loops with mouse drag. Click Done on RMB menu. 

   
3. Set No. of U and V Control Points to 7 and 10 each, click Preview. 

 
(Violet axis: U direction, Green axis: V direction) 

4. Click OK. 
5. Delete all surfaces in project window. 
6. Repeat the above step2. 
7. Check Swap UV axis and Use Loop Data of Loop Options, and click 

Preview. 

 
8. Click OK. 
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Auto Surfacing 
The Auto Surfacing operation automatically makes all patch boundaries and 
generates a watertight, smooth surface. You can determine patch count, boundary 
matching, and the amount of detail you want. If you select Modify Patch Network 
option, the application shows you quadrangular patch network based on a target 
patch count. A patch boundary is defined by four polylines traced on the polygonal 
surface. Pixform Pro provides several tools for editing a boundary layout and 
determining where the boundaries should be placed on the model. During editing a 
boundary layout, you can relax the patch network repeatedly until the boundaries are 
relaxed to the desired positions. 
 
Exercise 1: No Reference Shell, Without Editing Patch Network 

1. Open “shoe_auto_input.mdl” under the “surface_wb” folder. 
2. Select Surface > Create > Auto Surfacing menu, pick the shell and itself as 

a reference shell. 
3. Set No. of Surfaces and No. of Control Points to 100 and 10 each, and 

click OK. 
 

     
Before auto surfacing                            After auto surfacing 

 
Exercise 2: Use Reference Shell , Without Editing Patch Network 

1. Open “helmet_auto_input.mdl” under the “surface_wb” folder. 
2. Duplicate the shell by pushing Ctrl+C and Ctrl+V keys. 
3. Apply Tool > Decimate > High Quality to duplicate. 
4. Reduce to 500 faces. 

NOTE: About 1000 patches of surface, double the number of polygon mesh, 
will be created. 

     
    Original shell       Duplicate decimated 

5. Go to the Surface workbench. 
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6. Select Surface > Create > Auto Surfacing menu, pick the original shell and 
the duplicate as reference shell. 

7. Click OK with default values. 
8. Select Surface > Options > Drawing Quality > Boundary Only menu. 
9. Render the surface by the hot key R, and hide all entities by pushing the hot 

keys 2, 4 and 6. 

       
Surface boundaries Rendering surface 

 
Exercise 3: No Reference Shell, With Editing Patch Network 

1. Open “duct_auto.mdl” under the “surface_wb” folder. 
2. Click Surface > Create > Auto Surfacing menu and pick twice a shell. 
3. Set No. of Surfaces and No. of Control Points to 300 and 10, uncheck 

Match Surfaces Globally, check Modify Patch Network, and then click OK. 
4. Select Move Vertex option in the dialog box and move a vertex “A” to “B” as 

below. 

    
5. Select Rotate Edge option and pick two end points of an edge “C” twice. 

Select Move Vertex option and move two vertices “D” and “E” as below. 
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6. Change the viewpoint as below left and then select Move Vertex option and 
move four vertices “F”, “G”, “H” and “I” in order as below right. 

      
7. Change the viewpoint as below left and then select Move Vertex option and 

move a few vertices from “J” to “O” in order as below right. 

         
8. Change the viewpoint as below left and select Move Vertex option then move 

a vertex “P” as below right. 

   
9. Select Subdivide Vertex Star option and pick a vertex “Q.” Select Move 

Vertex option and move a few vertices from “a” to “f” in order. 
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10. Select Merge Vertex option and pick some pairs of vertices “g” and “h”, “i” 

and “j”, and “k” and “l”. Select Remove Vertex option and pick two vertices 
“m” and “n.” 

   
11. Press the RMB and click Relax Patch Boundary on it. 
12. Click OK in the dialog box to finish this operation. 
13. Click Surface > Options > Drawing Quality > Boundary Only menu. 
14. Click Surface > Options > Rendering Quality > High menu, and push R key 

to render surface. 
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Mirror 
The Surface Mirror operation mirrors surfaces against a reference plane. This 
reduces the time and resources needed to surface a symmetrical object. The 
mirrored surfaces are space surfaces and are not attached to the shell. 
 
Exercise: 

1. Open “mirror.mdl” under the “surface_wb” folder. 
2. Click Surface > Create > Mirror menu, and select all surfaces. 
3. Click Done on RMB menu, and then select a center plane. 
4. Render surface and hide all entities in the project window. 

   
 

Change UV & Propagate Isocurves 
The Change UV operation changes or propagates UV axis directions of untrimmed 
patches. The Propagate Isocurves operation matches the isocurve number of two 
patches neighboring each other. 
 
Exercise: 

1. Open “face_loop.mdl” under the “surface_wb” folder. 
2. Select Surface > Create > Polygon Fit > By Loops menu, and select all 

loops by mouse drag. Click Done on RMB menu. 
3. Set No. of U and V Control Points to 10 and 7 each, and click OK. 
4. Select Surface > Property > Show UV Axes menu. 
5. Select Surface > Edit > Propagate Isocurves menu, and pick first a patch in 

center and then pick a patch in its left. 

    
6. Repeat Propagate Isocurves operation for all surface patches. 
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7. Select Surface > Edit > Change UV menu, and select all patches by mouse 
drag. 

8. Check in Set All option, and click Change. 
9. Click Change again to propagate the direction of UV axes. 
10. Click OK button. 

    
11. Delete all surfaces in project window. 
12. Select Surface > Create > Polygon Fit > By Loops menu, and select all 

loops. 
13. Check in Use Loop Data option, and click OK. 

 
NOTE: Though surfaces of loops were deleted, you can recreate the previous 
structure of patches with Use Loop Data option. 

 

Rebuild 
The Surface Rebuild operation rebuilds the surface with the reassigned number of 
control points. This operation can be effectively used to minimize the gap distance 
between the surface and the polygon model as well as to make it easy to modify the 
surface. 
 
Exercise: 

(Being continued) 
1. Evaluate the surface fitting accuracy by Surface > Analysis > Surface/Shell 

Deviation. Select all surfaces by mouse drag and click Done on RMB menu. 
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2. Select Surface > Tool > Rebuild menu, and select all surface patches by 

mouse drag. Click Done on RMB menu. 
3. Set both of No. of U and V Control Points to 15, check in Preserve 

Continuity option, and click OK. 
4. Toggle off UV axes and hide all loops. Analysis the error deviation again. 

    
5. Render surfaces, and hide all entities. 
6. Show all surfaces by the hot key 5 and apply Surface > Analyze > 

Environment Mapping. 

           
 
Continuity & Match 
Typically, you need two surface patches to have matching (or continuous) values of 
some sort where they meet. If the patches touch, there is positional continuity 
between them. If they slope in the same direction, there is tangent continuity. 
Tangent continuity depends on positional continuity. If two patches don't touch, they 
won't have tangent continuity with each other.  
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Continuity between patches may be interpreted geometrically or parametrically. In 
addition to specifying a geometric relationship, the parametric interpretation is more 
rigorous, requiring that the parameter values between the two patches be 
proportional. Parametric continuity is generally trivial to achieve once geometric 
continuity is established, since the parameter values of patches may be adjusted to 
any arbitrary range. 
Specific abbreviations are used to describe continuity relationships depending on the 
desired continuity. Positional continuity (also known as zero-order continuity) is 
called G0 (Geometric) or C0 (Parametric). Tangent continuity (first-order) is called 
G1 or C1. Again, since cases of geometric continuity may normally be 
reparameterized to achieve parametric continuity, they are virtually equivalent. 
 
The Surface Match operation supports two types of continuity, C0 and C1. C0 
creates a watertight seam between surfaces by matching the control points along the 
seam, both in number and position. C1 creates a watertight seam that is also smooth 
by matching the control points along the seam and making the points on the surfaces 
tangent. 
 
Exercise: 

(Being continued) 
1. Select Surface > Analysis > Check Continuity > Position menu, and pick 

twice the boundary between two patches as shown below left. 
2. Select Surface > Analysis > Check Continuity > Tangency menu, and pick 

twice the boundary between two patches as shown below right. 

     
3. Select Surface > Tool > Match menu, and select all surfaces by mouse drag. 
4. Click Done on RMB menu. 
5. Click OK with Tangency(C1) option. 
6. Analyze again the continuity. 

 
T-Junction Match 
T-junctions occur when two or more patches are connected to one boundary of a 
surface patch. The T-Junction Match function gives you an ability to match 
untrimmed surfaces with T-junctions and to fit G1 or C1 continuous NURBS surfaces 
through these junctions. With T-junction capabilities, users are able to create the 
same curve network topology that they would create in their CAD system, preventing 
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the creation of unnecessary curve segments that are produced by systems that only 
support networks of untrimmed patches. 
The simplest case of T-junction is below. 

 
The T-Junction Match operation supports all kinds of T-junctions that an untrimmed 
patch has a corresponding patch on the opposite side for a T-junction patch. Some 
examples are below. 

     
The below is the only unsupported case in which a T-junction patch doesn’t meet at 
the corresponding position with another T-junction patch on the other side. 

 
 
Smooth 
The Surface Smooth operation stretches surface to make a smooth shape. The 
boundary of the surface resulting from this operation can be disjointed from the 
adjacent surfaces. Thus, the disjointed surfaces can be matched again with the 
Match operation. 
 
Exercise: 

(Being continued) 
1. Select Surface > Tool > Smooth menu, and select all surfaces by mouse 

drag. 
2. Set Number of iterations to 3 and turn off the check box of Move Boundary 

Vertices, and click OK. 
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3. Compare the smoothness with the step 6 of the Rebuild operation above by 
Surface > Analyze > Environment Mapping. 

 
Apply To Shell 
The Apply To Shell operation converts the surfaces into a polygonal shell through 
the tessellation process, and then combines the new polygon shell to the original 
shell. As a result, the original polygon surface has more smoothness. 
 
Exercise: 

1. Open “face_curve.mdl” under the “surface_wb” folder. 
2. Select Surface > Tool > Apply To Shell menu, and pick the deformed patch. 
3. Click OK with default option. 

                        
      Before applying to shell   After applying to shell 

 
Trim 
The Surface Trim operations trims a surface by a closed curve loop or divides a 
selected untrimmed surface to two trimmed surfaces with a given curve. 
The Surface Untrim operation removes the trimmed boundaries of a trimmed surface. 
So you can reconstruct an untrimmed surface of a trimmed one. 
 
Exercise: 

(Being continued) 
1. Show all curves by pushing the hot key 3. 
2. Go to the Curve workbench. 
3. Select Curve > Tool > Rebuild menu, and select curves by mouse drag as 

shown below. 
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4. Click Done on RMB menu. 
5. Check Use existing interpolation points option, and click OK. 

NOTE: You must refit all curves on polygonal surface before applying the 
surface trim operations because the polygon is refitted on the surface patch 
by Apply To Shell operation. 

6. Select Surface > Trim > Divide menu, and select a surface and a curve as 
below. At this time, the picked side of surface against the curve is remained. 

     
7. Select Surface > Trim > Add Loop menu, and pick a surface. 
8. Pick closed curves with starting from an upper long curve as below. 
9. Click Done on RMB menu. 

    
NOTE: The isocurves in the left side of first selected curve are left after 
trimming. Selected curves should be closed but the selection order is not 
important. 
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10. Apply Surface > Trim > Add Loop to the closed curves of left eye. 

 
11. Apply same operation to the right eye, but inverse the direction of one of two 

curves to trim the inside of eye out. 

      
  Inversing of curve direction       Trimming surface 

 
Detach Surface 
The Detach Surface operation disconnects surfaces from the shell that they 
connected. Then you can control surfaces independent of the shell. 
 
Exercise: 

1. Open “duct.mdl” under “surface_wb” folder. 
2. Push Ctrl+T key, select “duct”, and move it as shown below left. 
3. Click Done on RMB menu. 

                
                                Shell Trackball                     Transformed with surface 

4. Click Surface > Tool > Detach From Shell menu, and select all surfaces. 
5. Click Done on RMB menu. Apply Shell Trackball to the shell. 
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                          Detached surface                      Transformed shell only 
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9.  API 
 
The Pixform Pro API(Application Programming Interface) is an OLE (Object Linking 
and Embedding) programming interface to Pixform Pro. The API contains hundreds 
of functions that you can call from Visual Basic, VBA (Excel, Access, etc.), C++, 
Java, or Pixform Pro macro files. These functions provide direct access to Pixform 
Pro functionality. Note that Pixform Pro API is compatible to RapidForm API. 
 
Automation 
Automation (formerly called OLE Automation) is a technology that allows software 
packages to expose their unique features to scripting tools and other applications. 
Automation allows applications to communicate, exchange data, and control one 
another. It allows a client application to create and control an object, using the 
exposed object's interface. An Automation object is an object that is exposed to other 
applications or programming tools through Automation interfaces. Automation uses 
the Component Object Model (COM), but may be implemented independently from 
other OLE features, such as in-place activation.  
Using Automation,  
* Create applications and programming tools that expose objects. 
* Create and manipulate objects exposed in one application from another application. 
* Create tools that access and manipulate objects. These tools can include 
embedded. 
 
Automation in Pixform Pro 
Pixform Pro APIs are designed based on Automation. This means that user can 
access Pixform Pro objects and reuse Pixform Pro codes to develop their own 
functions and applications. This is a great benefit to Pixform Pro users to customize 
Pixform Pro according to their purpose. Most of fundamental Pixform Pro Objects 
like shell, vertex, face, curve, and surface are accessible through automation. In 
addition to it, Pixform Pro made a lot of powerful functions as OLE objects, which are 
grouped as curve tools, surface tools, mesh tools, point tools, select tools, reference 
geometry tools, and draw tools. Pixform Pro have integrated Visual Basic for 
Application, so you don't need to use a separate development environment to write 
your programs. However, you can write programs that control the Pixform Pro engine 
in any language that supports Automation. For example, you can create and edit 
simple macros that can replace series of menu clicking and even insert powerful 
functions that are not in menus in Visual Basic editor. If you are familiar with MS 
office automation, you can understand the power of automation. You can create 
independent executable application that can use Pixform Pro data structure and 
functions combined with other applications objects instead of writing a code from a 
scratch.  
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Pixform Pro API supports all of Pixform Pro core data structure and most of menu as 
Automation objects. 
 
Solutions Using Pixform Pro APIs 
(1) Simplification of work process 
If you have a series of tasks that you perform over and over again in Pixform Pro, 
you can automate these tasks in Pixform Pro by using macros. A macro is a set of 
computer instructions that you can record and associate with a shortcut key 
combination or a macro name. Then, when you press the shortcut key combination 
or click the macro name, your computer program carries out the instructions of the 
macro. This saves you time by replacing an often-used, sometimes lengthy series of 
actions with a shorter action. For example, instead of clicking several menus and 
buttons to manipulate your models in Pixform Pro, you can record those steps in a 
macro and then just click the macro to change the model as you intend in one step. 
Pixform Pro lets you automate not only keystrokes, but also most of the actions you 
can perform in Pixform Pro. 
(2) Creation of new functions 
Pixform Pro support OLE automated APIs, with which you can write your own codes 
that does special functions for you. You can record or write macros to make Pixform 
Pro perform a series of related actions that are available on menus or toolbars. In 
addition to it, you can write code by hand to make Pixform Pro perform actions that 
aren't available on menus or toolbars. Pixform Pro supports about 800 APIs. Some 



 

 
 

9-3 

of the APIs does the same functions as those in menu, but many of the APIs support 
creating basic entities like vertices, triangles and nurbs, and also support high-end 
functions like triangulation and decimation. For example, you can make a new 
function of importing a special file format. You can parse the file with your algorithm 
and add vertices and triangles to Pixform Pro. 
(3) Development of independent applications 
OLE automated APIs enable you to create stand-alone applications that use Pixform 
Pro functions. Solutions built with Pixform Pro are developed and deployed more 
quickly than those built from scratch. Developers can reuse the power and 
functionality of the host application and develop solutions with any computer 
languages that support OLE automated API. 
 
Macro Menu 
Macro menu provides commands for managing addins and creating, editing and 
managing macros. 
If you have a series of tasks that you perform over and over again in Pixform Pro, 
you can automate these tasks in Pixform Pro by using macros. A macro is a set of 
computer instructions that you can record and associate with a shortcut key 
combination or a macro name. Pixform Pro contains Visual Basic for Application 
module (VBA). Using this VBA, user can create and edit macros. 
 
Addin Manager… 
Macro > Addin Manager… command displays the Add-in manager dialog. If a user 
has installed any add-ins, this dialog provides all available addins. For each addin, 
user can set Loaded/Unloaded, Load on Startup and Command Line options. 
 
Addins 
Macro > Addins show all the loaded addins. A user can execute any loaded addins 
by selecting it on this menu. 
Pixform Pro API supports about 800 functions, which are designed based on OLE 
automation. Using these APIs, user can develop custom functions and register it as 
addins.  
 
Macros 
Macro > Macros command displays the Pixform Pro macro dialog. A user can run, 
edit and even debug existing macros and create new macros. 
 
Record 
Macro > Record command provides commands to record macros. In Pixform Pro, 
this command is supported only for the following operations: 
Triangulate 2D, Register Fine, Merge Shells, Smooth Shell/Region, Decimate 
Shell/Region/LargeShell, Subdivide Shell/Region, Remesh Global/Local, Shrink 
Shell/Region, Divide/Mirror, Offset, Separate Clusters, Thicken Shell, Fit Shell To 
PointCloud/Meshes 
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- Macro > Record > Start command starts recording a macro. This macro is saved in 
‘ThisDocument’ in the current project. 
- Macro > Record > Pause command pauses recording the macro for a while. 
- Macro > Record > Resume command continues recording the macro. 
- Macro > Record > Stop command finishes recording the macro. 
- Macro > Record > Run command runs the recorded macro. 
 
Visual Basic Editor 
Macro > Visual Basic Editor command displays Visual Basic for Application editor 
integrated into Pixform Pro. Pixform Pro provides an integrated development 
environment for convenient development of VBA projects. 
Most of Pixform Pro data can be access as objects in Visual Basic. Therefore, a user 
can combine power and functionality of VBA with Pixform Pro. 
User can make form based macros in addition to simple macros. 
 
Simple Macro Creation 
If you have a series of tasks that you perform over and over again in Pixform Pro, 
you can automate these tasks in Pixform Pro by using macros. A macro is a set of 
computer instructions that you can record and associate with a shortcut key 
combination or a macro name. Then, when you press the shortcut key combination 
or click the macro name, your computer program carries out the instructions of the 
macro. 
 
Let’s make a simple macro. For this example, let’s say that you want to make a 
complete model from a few scan data of point clouds taken from different viewpoints. 
First, you have to import all scan data to Pixform Pro and convert the point clouds to 
polygon surfaces as a pre-process for registration. Converting point clouds to 
polygon surfaces requires a series of Pixform Pro functions. You can make it as a 
single command by creating a macro. 
 
Exercise: 
1. Open ‘venus_point.mdl’ under ‘scan_wb’ folder. 
2. On the Macro menu in Pixform Pro, click Macros... This displays the Pixform Pro 
Macros dialog box. 
3. Input the name of a new macro in Macro name box and click Create. Here, type 
‘SimpleMacro’ for the new macro name. This displays the Visual Basic editor. 
4. Write your code between Sub SimpleMacro() and End Sub. This macro will be 
located in VBAProject->Module1 as SimpleMacro. 
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5. Write the following codes to convert point clouds to polygon surfaces. 
(This codes are included to the “SimpleMacro.bas” file in the “Tutorial/API” directory) 

01    Dim err As RFErrorCode 
02    Dim sh As RapidForm.RFShell 
03    Dim shID() As RFEntityID 
 
04    Set sh = RapidForm.Application.Shell 
05    nSh = Document.GetShellCount 
06    ReDim shID(nSh) 
07    dummy = model.EnumShells(shID(0)) 
 
08    For i = 0 To nSh - 1 
    ' Scan Mode: Build -> Filter Noise 
09        err = PointTools.FilterNoisePoints(shID(i), True, 0, 100) 
10        If err <> RF_SUCCESS Then 
11            MsgBox "Error while running Filtering Noise. Code Number is:" & err 
12            Exit Sub 
13        End If 
14        Document.RegenShell shID(i) 
     
    ' Scan Mode: Build -> Triangulate -> 2D 
15        err = PointTools.Triangulate2D(shID(i), RF_TRIANGULATE_DIRECTION_MINUS_Z, 13, 0, 0, 0) 
16        If err <> RF_SUCCESS Then 
17            MsgBox "Error while running Triangulating Points. Code Number is:" & err 
18            Exit Sub 
19        End If 
20        Document.RegenShell shID(i) 
 
21    Next 

01: Every Pixform Pro APIs return an error code as a type of RFErrorCode. 
04: Pixform Pro shell objects can be accessed only through the shell instance in 
Application. 
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07: All the entities in Pixform Pro have unique ID. All the shell IDs in current model 
can be obtained by passing the first element of RFShell array. 
10: If Pixform Pro API is completed successfully, it returns RF_SUCCESS constant. 
14: When a core data has been modified, all shells must be regenerated. This 
operation updates not only Pixform Pro core data but also the project tree. 
 
6. To run this macro, select Module1.SimpleMacro in Pixform Pro Macros dialog 
box. Click Run to execute this macro for the current model. 

 
7. To display shaded images, push F4 key. 

  
 
Global Macro Creation in Pixform Pro 
The SimpleMacro macro of the previous example is attached to the model file. 
Therefore, it cannot be used in other models. To solve this problem, Pixform Pro 
supports a global macro library. You can find global macros in the Library project in 
Project pane of Visual Basic editor. The macros in the Library project can be called 
regardless of model files and is stored in a separate file named 
‘RFDefaultMacro.mcr’ under Pixform Pro root directory. 
In this example, we make the SimpleMacro macro in ‘venus_point.mdl’ file as a 
global macro. 
 

Exercise: 
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1. Open ‘venus_point.mdl’ under ‘scan_wb’ folder. (Previous exercise should be 
done first) 
2. On the Macro menu in Pixform Pro, click Visual Basic Editor. 
3. You can see SimpleMacro in VBAProject project in the Project pane. Use drag 
and drop to copy the SimpleMacro to Library project. 

     
 
4. To run this global macro, change Macros in as Library and select 
Module1.SimpleMacro in Pixform Pro Macros dialog box. Click Run to execute 
this macro for the current model. 

 
 
Form-Based Macro Creation 
Pixform Pro has integrated Visual Basic for Application (VBA) to create and edits 
macros in Pixform Pro edition. This environment enables user to combine the power 
and functionality of VBA with Pixform Pro functions to customize Pixform Pro. User 
can make a form like in Visual Basic and use objects all the time—controls such as 
command buttons, user forms, databases, and fields. In this example, we will make 
the previous example as a form-based macro and add a clean polygon function. 
 
Exercise:  
1. Open ‘venus_point.mdl’ under ‘scan_wb’ folder. 
2. On the Macro menu in Pixform Pro, click Macros... This displays the Pixform Pro 
Macros dialog box. 
3. Input the name of a new macro in Macro name box and click Create. Here, type 
‘FormMacro’ for the new macro name. This displays the Visual Basic editor. 
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4. Insert a UserForm in VBAProject and create layout buttons. Each control’s type 
and property setting is shown in the table below. 

 
 

Control Type Property  
Name btnFilterNoise CommandButton 
Caption Filter noise 
Name btnTriangulate2D CommandButton 
Caption Triangulate 2D 
Name btnCleanPolygon CommandButton 
Caption Clean Polygon 
Name lblFilterNoise01 Label 
Caption Minimum cluster to cluster distance 
Name lblFilterNoise02 Label 
Caption Maximum cluster size to be filtered 
Name lblTriangulate2D01 Label 
Caption Projection direction 
Name lblTriangulate2D02 Label 
Caption Delete faces 
Name lblReport Label 
Caption Report 
Name chkboxFNAutomatic 
Caption Automatic 

CheckBox 

Value True 
Name ChkboxT2DMaxEdgeLen CheckBox 
Caption Maximum edge length is larger than 
Name chkboxT2DArea CheckBox 
Caption Area is larger than 
Name chkboxT2DEdgeLenRatio CheckBox 
Caption Max/Min edge length ratio is larger than 
Name chkboxT2DFaceAngle CheckBox 
Caption Facing angle is larger than 
Name chkboxCPNonManifold 
Caption Non-manifold faces 

CheckBox 

Value True 
Name chkboxCPRed CheckBox 
Caption Redundent faces 
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 Value True 
Name chkboxCPCross 
Caption Crossing faces 

CheckBox 

Value True 
Name optbtnT2DMZ 
Caption -Z 

OptionButton 

Value True 
Name optbtnT2DPZ OptionButton 
Caption +Z 
Name optbunT2DCV OptionButton 
Caption Current Viewpoint 

TextBox Name txtboxFNDist 
Name txtboxFNMaxSize TextBox 
Value 100 

TextBox Name txtboxT2DmaxEdgeLen 
TextBox Name txtboxT2DArea 
TextBox Name txtboxT2DEdgeLenRatio 
TextBox Name txtboxT2DFaceAngle 

Name txtboxReport TextBox 
Multiline True 

 
5. On the View menu in Visual Basic editor, click Code to insert the following 
codes in the UserForm created in the previous step. 
(The following codes are included to the “UserForm1.frm” file in the “Tutorial/API” 
directory) 

Dim err As RFErrorCode 
 
Private Sub btnFilterNoise_Click() 
    Dim curShell As RFEntityID 
    err = SelectTools.GetCurrentShell(curShell) 
    If chkboxFNAutomatic.Value = True Then 
        err = PointTools.FilterNoisePoints(curShell, True, 0, txtboxFNMaxSize.Value) 
    Else 
        err = PointTools.FilterNoisePoints(curShell, False, txtboxFNDist.Value, txtboxFNMaxSize.Value) 
    End If 
 
    If err <> RF_SUCCESS Then 
        txtboxReport.Value = txtboxReport.Value & Chr(13) & Chr(10) & _ 
            "Error while running Filter Noise. Code Number is:" & err 
        Exit Sub 
    Else 
        txtboxReport.Value = txtboxReport.Value & Chr(13) & Chr(10) & _ 
            "FilterNoise is applied successfully." 
    End If 
 
    Document.RegenShell curShell 
End Sub 
 
Private Sub btnTriangulate2D_Click() 
    Dim curShell As RFEntityID 
    Dim direction As RFTriangulateDirection 
    Dim length As Double, area As Double, ratio As Double, angle As Double 
     
    err = SelectTools.GetCurrentShell(curShell) 
    If optbtnT2DMZ.Value = True Then 
        direction = RF_TRIANGULATE_DIRECTION_MINUS_Z 
    ElseIf optbtnT2DPZ.Value = True Then 
        direction = RF_TRIANGULATE_DIRECTION_PLUS_Z 
    Else 
        direction = RF_TRIANGULATE_DIRECTION_CURRENT_VIEW 
    End If 
     
    If chkboxT2DMaxEdgeLen.Value = True Then 
        length = txtboxT2DMaxEdgeLen.Value 
    Else 
        length = 0 
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    End If 
     
    If chkboxT2DArea.Value = True Then 
        area = txtboxT2DArea.Value 
    Else 
        area = 0 
    End If 
     
    If chkboxT2DEdgeLenRatio.Value = True Then 
        ratio = txtboxT2DEdgeLenRatio.Value 
    Else 
        ratio = 0 
    End If 
     
    If chkboxT2DFaceAngle.Value = True Then 
        angle = txtboxT2DFaceAngle.Value 
    Else 
        angle = 0 
    End If 
     
    err = PointTools.Triangulate2D(curShell, direction, length, area, ratio, angle) 
 
    If err <> RF_SUCCESS Then 
        txtboxReport.Value = txtboxReport.Value & Chr(13) & Chr(10) & _ 
            "Error while running Triangulating Points. Code Number is:" & err 
        Exit Sub 
    Else 
        txtboxReport.Value = txtboxReport.Value & Chr(13) & Chr(10) & _ 
            "Triangulate2D is applied successfully." 
    End If 
 
    Document.RegenShell curShell 
    CheckPolygon 
End Sub 
 
Function CheckPolygon() 
    Dim curShell As RFEntityID 
    Dim countNon As Long, countRed As Long, countCross As Long 
    err = SelectTools.GetCurrentShell(curShell) 
     
    err = MeshTools.FindAbnormalFaces(curShell, True, True, True, countNon, countRed, countCross) 
    If err <> RF_SUCCESS Then 
        txtboxReport.Value = txtboxReport.Value & Chr(13) & Chr(10) & _ 
            "Error while running abnormal face search. Code Number is:" & err 
        Exit Function 
    Else 
        txtboxReport.Value = txtboxReport.Value & Chr(13) & Chr(10) & _ 
            "------ Abnormal faces in current shell ------" & Chr(13) & Chr(10) & _ 
            "- Non-manifold faces : " & countNon & Chr(13) & Chr(10) & _ 
            "- Redundent  faces : " & countRed & Chr(13) & Chr(10) & _ 
            "- Crossing faces : " & countCross 
    End If 
 
    Document.RegenShell curShell 
End Function 
 
Private Sub btnCleanPolygon_Click() 
    Dim curShell As RFEntityID 
    Dim countNon As Long, countRed As Long, countCross As Long 
    err = SelectTools.GetCurrentShell(curShell) 
     
    err = MeshTools.FindAbnormalFaces(curShell, True, True, True, countNon, countRed, countCross) 
    err = MeshTools.CleanAbnormalFaces(curShell, chkboxCPNonManifold.Value, _ 
        chkboxCPRed.Value, chkboxCPCross.Value) 
 
    If err <> RF_SUCCESS Then 
        txtboxReport.Value = txtboxReport.Value & Chr(13) & Chr(10) & _ 
            "Error while running  Clean Polygon. Code Number is:" & err 
        Exit Sub 
    Else 
        txtboxReport.Value = txtboxReport.Value & Chr(13) & Chr(10) & _ 
            "Clean Polygon is applied successfully." 
    End If 
 
    Document.RegenShell curShell 
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    CheckPolygon 
End Sub 

 
6. To make FormMacro macro to display the UserForm, type the following codes in 
FormMacro function. 
(This codes are included to the “Module1.bas” file in the “Tutorial/API” directory) 

    Dim myForm As UserForm1 
    Set myForm = New UserForm1 
    Load myForm 
    myForm.Show 

 
7. To run this macro, select Module1.FormMacro in Pixform Pro Macros dialog 
box. Click Run to execute this macro for the current model. 
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10. Hardware 
 
Pixform Pro supports external hardware devices that can help in the modeling 
process: the Magellan/SpaceMouse®. 
 
Space Mouse 
The Magellan/SpaceMouse® is a device similar to a joystick in purpose, but it also 
provides movement control with 6 degrees of freedom. Pull up or push down to move 
your model, eye point up or down. Push left or right to move your model left or right. 
Pull towards you or push away to move your model nearer or farther away. Orient 
your model on the screen by simply twisting in any direction to rotate it around the X, 
Y or Z axis (pitch, roll, yaw). With this 3D motion controller, you can intuitively zoom, 
pan and rotate models, exploring and navigating your designs as naturally as if they 
were objects in the real world. 
 

                
 
Pixform Pro allows you to control eight (1~8) programmable buttons of the 3D motion 
controller. It can be performed by the Customize Magellan command of the View 
menu. To map a function to any buttons, just click that function in the menu toolbar 
after selecting the corresponding button. 
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11. Appendix 
 
This appendix lists all the commands available in the basic platform without any 
license key. 
 
Basis Command List 
The following is the table of commands available in Pixform Pro Basis (Basic 
platform). You can execute the following commands, though you don’t have any 
license for Pixform Pro. 

Menu Command 
File   New   

   Open   
  Save  
  Save As  
  Save As Default MDL  
   Import  
  Publish ICF  
   Page Setup   
   Print Preview   
   Print   
   Preferences   
   Summary Info   
   Recent Files    
   Exit   

Select   Entities   Vertex/Face/Shell 
     Curve/Surface/Loop 
     Line on Section Deviation 
   Custom Region   
   Flood Fill   
   All   
   None   
   Inverse   
   Boundary Vertices   
   Boundary Faces   
   Vertices Around   Curves/Surfaces 
   Faces Around   Curves/Surfaces 
   Enlarge   One Depth 
     Feature region > Face Normal/Face Curvedness 
   Shrink One Depth   
   From Selected Vertices   
   From Selected Faces   
   Mode   Line 
     Rectangle 
     Circle 
     Polyline 
     Freehand 
     Paint Brush 
   Option   Select Visibles Only 
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     Select Through  
     Active Shell Only 
     Set Brush Size   

Edit   Delete   Vertex/Face/Shell 
     Section Deviation 
     Note/Annotation/GT/Dimension 
  Transform  Shell Trackball 
   Material   

Information   Vertex   
   Face   
   Region   
   Shell   
   Model   
   Curve   
   Loop   
   Template   
   Surface   
   Ref. Geometry   
   Show Boundaries   
   Shown Whole Deviation   
   Section Deviation   
   Loop in Section Deviation   
   Annotation   
   Geometric Tolerance   
   Dimension   
  Check Interference  
   Note   Add 
   Edit 
   Move 
   Delete 
     Show All 
   Hide All 
     Slant Line 
   Plumb Line 
   Report Information   Add Note 

Measure   Distance   Point/Point > Along Line/Along Surface 
     Point/Ref. Vector 
     Point/Ref. Plane 
     Ref. Plane/Ref. Plane 
     Perimeter > Point & Plane/Points 
   Radius   Circle (3 Points) 
     Sphere (4 Points) 
     Rounded Area Radius 
   Angle   Ref. Plane/Ref. Plane 
     Ref. Plane/Ref. Vector 
     3 Points 
     2 Vectors 
   Cross Section   Shell/Model 
   Shell/Shell Deviation   
   Curvature Plot   
   Environment Mapping   
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   Auto Measuring   
   Face Angle Plot   
   Contour Lines   Shell/Model 

Ref. 
Geometry  Delete   

View   Zoom Window   
   Zoom Previous    
   Zoom to Fit   
   Set Working Region   
   Explode Shells   
   Reset   
   Set Trackball Center   
   Reset Trackball Center   
   Shading Method  Flat/Smooth/Point/Depth Cueing/Phong Shading 
   Display Mode   Point Set/ Wireframe 
     Hidden Line/ Shaded 
     Shaded With Edges/ Transparent 
     Textured 
   View Point   Front/Back/Left/Right/Top/Bottom/Iso 
   Add Current View   
   Bounding Box   
   Axis   
   Grid   
   Skins   Window Default/ Office XP  
  Mac/ Funny/ User Image 
   Customize Color Bar   
   Customize Font   Small Text/Large Text 

Help   Pixform Pro Help   
   Pixform Pro API Help   
   Pixform Pro Tutorials   
   OpenGL Information   
   Request License   
   About Pixform Pro   

Curve   Delete   
   Property   Show All/Hide/Hide All 
     Show Control Points 
     Show/Hide with Shell 
     Show Direction 
     Show Node 

Loop   Delete   
   Property   Show All/Hide/Hide All 
   Options   Show Direction 

Surface   Delete   
   Property   Render 
     Show All/Hide/Hide All 
     Show Control Points 
     Show Edges 
     Show UV Axes 
     Show/Hide with Shell 
   Options   Rendering Quality > High/Mid/Low 
     Drawing Quality > High/Mid/Low/Boundary Only 
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     Quick Rendering 
Template   Delete   

   Property   Show All/Hide/Hide All 
   Options    

Inspection   Whole Deviation   Hide All 
     Delete All 
     Delete Shown 
   Section Deviation   Show All  
     Hide All 
     Delete All 
     Delete Shown 
   Annotation   Large Annotation 
     Small Annotation 
   Show Name 
     Slant Line 
     Plumb Line 
     Show/Hide With Deviation 
   Geometric Tolerance   Show All 
     Hide All 
     Slant Line 
     Plumb Line 
     Show Graphical Display 
   Show Name 
     Show/Hide With Deviation 
   Dimension   Show All 
     Hide All 
   Show Name 
     Show/Hide With Deviation 

Solid   Property   Show All 
     Hide 
     Hide All 
     Show/Hide With Shell 
   Delete   
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12. Glossary 
 
The following sections define many of the basic terms and concepts you should 
know in order to use Pixform Pro effectively. 
 
A 
ACIS  
A component software that provides a solid modeling "engine" (also called "kernal") 
used by many commercial and research organizations as the core of CAD/CAM/CAE 
applications. Creates models in the SAT format. (Note: ACIS is not an acronym). 
(Spatial Technology Corp.) 
 
Anti-aliasing  
Anti-aliasing is sub pixel interpolation, a technique that makes edges appear to have 
better resolution. 
 
API 
API (Application Programming Interface) is a series of functions that programs can 
use to make the operating system do their dirty work. It serves as a software 
interface to be used by other programs. 
 
Aspect Ratio 
Ratio of width to height 
 
B 
Bezier Curve(Surface) 
A smooth curve controlled by three or more control points. The Bezier curve always 
intersects the first and last control point, but is usually only influenced by the others. 
The Bezier surface is an extension of the Bezier curve. Named after its inventor, 
Pierre Bézier, a CAD system designer in France. 
 
Bitmap  
A Bitmap is a pixel by pixel image. 
 
Boundary 
Borders of a model 
 
Boundary Edge 
Edge of a polygon that is not shared with another polygon 
 
Boundary Representation (B-rep) 
A solid modeling database structure that defines and stores a solid as a topological 
set of explicitly defined vertices, edges, and faces. 
 
Box  
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A closed box composed of three pairs of rectangular faces placed opposite each 
other and joined at right angles to each other, also known as a rectangular 
parallelepiped.  
 
C 
C0 or G0 Continuity 
Positional continuity. Two surfaces that share a set of boundaries are C0 or G0 
continuous when the adjoining edges of the surfaces match up exactly with respect 
to surface position.  
 
C1 or G1 Continuity 
Tangential continuity. Two surfaces that share a set of boundaries are C1 or G1 
continuous when the normals at the boundaries of those surfaces are exactly aligned 
in direction and are the same in magnitude.  
 
C2 or G2 Continuity 
Curvature continuity. Two surfaces that share a set of boundaries are C2 or G2 
continuous when they have the same curvature values where they meet. 
 
CAD 
Computer Aided Design 
 
Centroid 
The centroid (sometimes called a center of gravity) is the center point or middle point 
of the area. Traditionally, this point is found by cutting the area out of cardboard and 
balancing it on a pin. The balance point location is the centroid. 
 
CMM 
Coordinate Measuring Machine 
 
Control Points 
A set of points that parameterize and control the shape of a NURBS curve or surface 
 
CT 
CT (Computed Tomography) scans measure photon linear attenuation of a tissue 
relative to water. These scans produce high-resolution anatomic images because the 
contrast between soft tissue and skeletal structures such as calcifications and bone 
are easily seen with this modality and has a spatial resolution of about 1 mm. 
 
Curvature 
This is a mathematically-defined term which refers to the amount of roundness 
located at a point on a curve or surface. If a curve is flat, then its curvature is zero. 
As the curve becomes more rounded, the radius of curvature goes down and the 
curvature goes up. Curvature 'k' = 1 / rho, where rho is defined as the radius of 
curvature. These two values ('k' and 'rho') are inversely related. 
 
Curve 
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A curve is a mathematical function that describes the path of a point moving through 
space. In Pixform Pro, curves are displayed by sampling the mathematical 
description of the curve at specified intervals, then drawing line segments between 
these sample points. Pixform Pro uses NURBS to represent the curve geometry. 
 
D 
Decimation 
An operation that reduces the count of entities. This operation usually attempts to 
preserve the object's overall shape and sharp features. 
 
Depth Cueing  
Depth cueing is the lowering of intensity as objects move away from the viewpoint. 
 
DICOM  
The Digital Imaging and Communications in Medicine (DICOM) standard was 
created by the National Electrical Manufacturers Association (NEMA) to aid the 
distribution and viewing of medical images, such as CT scans, MRIs, and ultrasound. 
 
Displacement map 
A function defined on NURBS surfaces that depicts the deviations between a 
NURBS surface and the original polygonal mesh. 
 
Draft Angle 
The amount of angle required to permit release of the part from the tool, measured 
from the die removal angle.  
 
E 
Edge 
Line between two connected vertices on a polygon 
 
F 
Face 
A face is a triangle composed of three vertices, and it is defined as three edges 
connected with each other. 
 
Feature 
In Pixform Pro, the base feature can be an analytic shape such as planes(including 
box), a sphere, cylinder, or cone. And the advanced feature can be one of a hole, cut, 
fillet, chamfer, or an extrusion, a revolution, or a free-form shape such as a sweep or 
loft. 
 
Feature Curve 
Curve that maintain characteristics in the feature topology of a model 
 



 

 
 

12-4 

Feature-based modeling 
Modeling technique in which you design the part by applying features that are similar 
to how the part is manufactured (e.g., holes, ribs, fillets, cuts, and bosses) 
 
Flat Shading  
The flat shading method is also called constant shading. For rendering, it assigns a 
uniform color throughout an entire polygon. This shading results in the lowest quality, 
an object surface with a faceted appearance and a visible underlying geometry that 
looks 'blocky'. 
 
G 

Gaussian Curvature  
The double curvature of a point on a surface. If a surface is developable (flat in one 
direction), then the Gaussian curvature is zero. As the surface becomes more curved 
in two directions (twisted), the Gaussian curvature increases (positively or 
negatively). Mathematically, the Gaussian curvature is the product of the two 
principal curvatures. 
 
Geometric Dimensioning and Tolerancing (GD&T) 
Geometric dimensioning and tolerancing (GD&T) is a language used on mechanical 
engineering drawings composed of symbols that are used to efficiently and 
accurately communicate geometry requirements for associated features on 
components and assemblies. 
 
Geometric Tolerance (GT) 
A geometric tolerance describes the degree to which a nominal design feature can 
vary while satisfying functional requirements. It also describes the variation that is 
allowed when fabricating parts from a design. Manufacturing processes have 
particular and repeatable ranges of variation. The tolerance associated with a 
process depends on expected process variation and the techniques used for 
measurement. In Pixform Pro, flatness, straightness, circularity and etc are defined 
as GT. 
 
Gouraud Shading  
Gouraud shading, one of the most popular smooth shading algorithms, is named 
after its French originator, Henri Gouraud. Gouraud shading, or color interpolation, is 
a process by which color information is interpolated across the face of the polygon to 
determine the colors at each pixel. It assigns color to every pixel within each polygon 
based on linear interpolation from the polygon's vertices. 
 
Grid  
A tessellation of congruent squares sometimes used to measure distance 
 
GUI 
Graphic User Interface 
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H 
Hidden lines  
Broken lines used to signify lines that normally wouldn't be seen in a drawing 
 
Healing  
A series of functions whose purpose is to correct geometric abnormalities contained 
within a surface or solid model. Common functions may include surface simplification 
(mapping spline surfaces to analytic shapes such as planes, cylinders, cones, etc.), 
face stitching, and edge gap repair. More advanced functions may include the ability 
to merge coincident vertices, repair self-intersections, and reduce and/or redeploy 
curve and surface control nodes. Programs typically perform healing on geometry 
that you import through neutral formats such as IGES, STEP, and SAT with 
problems caused by conditions ranging from imprecise geometric definitions to poor 
entity mapping to poorly written translator code. A CAD system may perform healing 
externally (on the neutral file), as it imports the neutral file, or internally after the 
neutral file is imported. 
 
Hybrid  
Solid modeling system that employs two or more distinct database structures (e.g., 
CSG and B-Rep) to store and define a solid. Hybrid systems are known for their 
ability to mix advanced surfacing and solid functions within the same database. 
Hybrid systems may also let you explode a solid, perform surface and solid functions 
on open volumes, and then sew the faces back into a solid. 
 
I 
IGES 
Initial Graphics Exchange Specification, the standard for exchanging geometric 
information 
 
Interpolation 
The process of defining a curve (or surface) that passes through a set of points. 
 
Isocurve(Iso-parameter curve) 
A set of curves on the surface that occur in the UV direction and define the surface 
shape. A parametric surface is typically crossed with flow lines that are constant U or 
V parameter curves on the surface, which are referred to either as isocurves. 
 
L 
LMB 
Left Mouse Button 
 
Loop 
A set of curves with ends that meet 
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M 
Manipulator 
An interactive control device, which is usually used to transform an object 
 
Model 
A model is a logical set of several shells. Only one model can exist on the workspace 
window.  
 
Mouse Drag 
Moving the mouse while pressing and holding the mouse button. 
 
MRI 
MRI (Magnetic Resonance Imaging) scans acquire highly detailed anatomic 
information. Magnetic pulse sequences highlight the different amounts of water 
(hydrogen protons) contained in anatomical structures and fluids. 
 
N 
Noise 
Erroneous data resulting from the scanning process. Usually represented as 
unnecessary points in a point cloud. 
 
Normal 
A vector perpendicular to a polygonal mesh 
 
NURBS 
Non-Uniform Rational B-Spline. This is a type of spline where the curve passes close 
to but not through the control points or knots and used in spline-based modeling. 
 
O 
OLE  
OLE (Object Linking and Embedding) allows users to integrate data from different 
applications. Object linking allows users to share a single source of data for a 
particular object. 
 
P 
Parameter  
For B-splines, this refers to the independent value or parameter that is used to define 
the curve or surface. For curves, the parameter is called 'u' and its value changes 
from 0.0 at one end of the curve to 1.0 at the other end. Rectangular-like B-spline 
surfaces have two parameters: constant 'u' for the row direction and constant 'v' for 
the column direction. Their values also range from 0.0 to 1.0, so that every 
combination of 'u' and 'v' values between 0.0 and 1.0 define the entire surface. 
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Parasolid  
A solid modeling engine used by many commercial and research organizations as 
the core of CAD/CAM/CAE applications. (Unigraphics Solutions Inc.) 
 
Parameterization  
The flow of the curves defining a parametric surface 
 
Patch 
A portion of a surface defined by a set of control points. The program allows you to 
deal with the surface on a patch-by-patch basis. 
 
Perspective view 
A view in which perspective can be observed. Perspective views are used to give a 
3D appearance. 
 

Phong Shading  
Phong shading is a sophisticated smooth shading method, originated by Phong Bui-
tuong. The Phong shading algorithm is best known for its ability to render precise, 
realistic specula highlights. During rendering, Phong shading achieves excellent 
realism by calculating the amount of light on the object at tiny points across the 
entire surface instead of at the vertices of the polygons. Each pixel representing the 
image is given its own color based on the lighting model applied at that point. Phong 
shading requires much more computation for the hardware than Gouraud shading. 
 
Point Cloud (or Point Set) 
A point cloud is defined as a set of points in 3D space. A point cloud may consist of a 
single point or several million points. In Pixform Pro, the number of points in a point 
cloud is limited only by the memory limitations of the host computer. 
 
Polyline 
A collection of n lines defined by the n +1 points that define the endpoints of each 
line segment 
 
Polygonal model 
A model composed of polygon faces. 
 
Primitives 
Pre-defined objects, either 2D or 3D, i.e., circle, square, arc, plane or sphere, cube, 
cylinder, cone, torus, and various polyhedrons. 
 
Profile 
A 2D sketch drawing on a reference plane. 
 
Propagate 
The process of creating equal numbers of isocurves across the boundary of two or 
more adjacent surface patches along the boundary's perpendicular direction 
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R 
Region 
A region is a user-selected set of vertex or face, which is just a temporary set in the 
job process. A region is released after the corresponding job is finished. 
 
Rendering 
The process of creating life-like images on a screen using mathematical models and 
formulas to add shading, color, and lamination to a 2D or 3D wireframe 
 
Reverse Engineering 
In general, the processing of understanding the design and funtionality of a product 
using a sample of the product itself. For CAD, the term refers more narrowly to the 
process of scanning or digitizing the shape of an object and turning that data into a 
model which can then be treated as a normal CAD model, ultimately to re-
manufacture the part or product. 
 
RMB 
Right Mouse Button 
 
RP (Rapid Prototyping) 
A various manufacturing processes as well as a burgeoning industry. RP processes 
involve devices--ranging from office modelers to four-ton machines--that accept 3D 
CAD files, slice the data into cross-sections, and construct layers from the bottom up, 
bonding one on top of the other, to produce physical prototypes for applications such 
as engineering form, fit, and function; soft tooling for prototypes; and patterns for 
hard tooling. The RP industry consists of RP systems, materials, and after-market 
products as well as a services sector. 
 
S 
SAT 
A file format for 3D solid geometry, created by systems that use the ACIS solid 
modeling engine. (Spatial Technology Corp.) 
 
Shell 
A shell is a logical set of several faces. Faces are usually connected with each other, 
but not always. Normally, polygon meshes obtained through triangulation process of 
a point cloud measured on one view are managed as a shell. 
 
Shell curve 
Curves that are automatically connected to a shell when they are created 
 
Shell surface  
Surfaces that are automatically connected to a shell when they are created 
 
Sketch  
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2D geometry, such as lines, arcs, circles, and curves, used to drive geometric 
features. The sketch environment contains a constraint manager that lets you place 
dimensional and relational constraints on geometry. 
 
SLA  
The 3D file format used by Stereolithography Apparatus (SLA) rapid prototyping 
machines. Can also be used as a general 3D file format for viewing. (3D Systems 
Inc.) 
 
Space curve 
Curves that are not connected to any shell. Space curves can be usually generated 
by importing foreign data formats such as IGES, STEP or VDAFS. 
 
Space surface 
Surfaces that are not connected to any shell and operations related to shell are not 
available. Space surfaces can be usually generated by importing foreign data 
formats such as IGES, STEP or VDAFS. They may be introduced by generic surface 
creation tools such as blend, loft, sweep, and N-boundary filling. 
 
STL(Stereolithography) 
Stereo Lithography file format. A rapid prototyping (RP) process, introduced in 1987 
by 3D Systems Inc. launched the RP industry. A Stereolithography Apparatus (SLA) 
machine builds physical models in this manner: it focuses an ultraviolet (UV) light 
onto the surface of a vat filled with liquid photopolymer. The light beam, moving 
under computer control, draws each layer of an object onto the surface of the liquid. 
Wherever the beam strikes the surface, liquid changes to solid. 3D parts are built 
from the bottom up, one layer at a time; when the part is finished, it is exposed to UV 
light for curing. (3D Systems Inc.) 
 
STEP 
The Standard for the Exchange of Product Model Data is a comprehensive ISO 
standard (ISO 10303) that describes how to represent and exchange digital product 
information. 
 
Surface (Patch) 
A surface is defined as a mathematical function that describes the geometry fit to 
polygonal meshes. A surface(called patch) is bounded by iso-parameter 
curves(called flow line), controlled by a selected set of control points in the bi-
direction, U-direction and V-direction. The surface is divided into 2 types, untrimmed 
and trimmed surface. The untrimmed surface has 4 boundary curves, while the 
trimmed surface has 2, 3, or more than 4 boundary curves. The trimmed surface is a 
special type of surface that is trimmed by its boundary curves after a basic surface, 
that is, an untrimmed surface is generated. Pixform Pro uses NURBS to represent 
the surface geometry. 
 
T 
Template  
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A function that copy, save, and reuse layouts. Thus, you can copy and use them on 
other parts of the same model. 
 
Tessellation 
Tessellation is the process of subdividing a surface into smaller shapes. To describe 
object surface patterns, tessellation breaks down the surface of an object into 
manageable polygons. Triangles or quadrilaterals are two usually used polygons in 
drawing graphical objects because computer hardware can easy manipulate and 
calculate these two simple polygons. 
 
Texture Mapping  
Texture mapping is based on a stored bitmap consisting of texture pixels, or texels. It 
consists of wrapping a texture image onto an object to create a realistic 
representation of the object in 3D space.  
 
Toggle 
To switch from one setting to another. The term toggle implies that there are only two 
possible settings and that you are switching from the current setting to the other 
setting. 
 
Toolbar  
Movable palette of tools that perform operations 
 
Topology  
Data that tells the software how to connect the entities 
 
Torsion  
A twisting deformation of a body about an axis in which straight lines that are initially 
parallel to the axis become helixes. In mathematics, it is defined by the magnitude of 
the derivative of the normal to the plane of curvature with respect to distance on the 
curve. 
 
Torus  
A torus is a surface having a single hole. The usual torus embedded in three-
dimensional space is shaped like a donut, but the concept of the torus is extremely 
useful in higher dimensional space as well. In general, tori can also have multiple 
holes. 
 
Transformation  
Change of coordinates; a series of mathematical operations that act on output 
primitives and geometric attributes to convert them from modeling coordinates to 
device coordinates. 
 
U 
Undercut  
A face that is oriented opposite to the direction in which the mold will be pulled. 
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UV Direction  
Each surface patch has two directions, U and V. Isocurves within a patch run in U or 
V direction. 
 
V 
VDAFS 
Vereinung Deutsche Automobilindustrie Flächen Schnittstelle is a German neutral 
file format for the exchange of surface geometry. It was developed to exchange free 
form surfaces and it became a DIN standard in 1986. VDAFS supports elementary 
curve and surface geometry entities and some topology to define more complex 
models. 
 
Vertex 
A single point defined by its Cartesian coordinates(X, Y and Z) 
 
Voxel 
A voxel is an element in a 3D volume. A voxel is the 3D equivalent of a picture 
element, or pixel. It is also defined as the smallest discrete spatial component of a 
digital volume. 
 
VRML(Virtual Reality Modeling Language) 
A language that lets Web browsers view and interact with 3D models; requires a 
special viewer. 
 
W 
Wireframe 
A geometric model that describes 3D geometry by outlining its edges. 
 
World Coordinates 
In 3D space, a coordinate system that enables the software and the artist to 
establish an exact location for objects, lights, or cameras. The origin of the world 
coordinate system is (0, 0, 0).  
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Please read this agreement carefully before opening the sealed
 package or the sealed disk package

Opening the sealed package or sealed disk package implies your acceptance of the terms and conditions of this agreement.

Roland License Agreement

Roland DG Corporation ("Roland") grants you a non-assignable and non-exclusive right to use the COMPUTER
PROGRAMS in this package ("Software") under this agreement with the following terms and conditions.

1. Coming into Force This agreement comes into force when you purchase and open the sealed package
or sealed disk package.
The effective date of this agreement is the date when you open the sealed package
or sealed disk package.

2. Property Copyright and property of this Software, logo, name, manual and all literature
for this Software belong to Roland and its licenser.

The followings are prohibited :
(1) Unauthorized copying the Software or any of its support file, program module

or literature.
(2) Reverse engineering, disassembling, decompiling or any other attempt to

discover the source code of the Software.

3. Bounds of License Roland does not grant you to sub-license, rent, assign or transfer the right granted
under this agreement nor the Software itself (including the accompanying items)
to any third party.
You may not provide use of the Software through time-sharing service and/or
network system to any third party who is not individually licensed to use this
Software.

You may use the Software by one person with using a single computer in which
the Software is installed.

4. Reproduction You may make one copy of the Software only for back-up purpose. The property
of the copied Software belongs to Roland.
You may install the Software into the hard disk of a single computer.

5. Cancellation Roland retains the right to terminate this agreement without notice immediately
when any of followings occurs :
(1) When you violate any article of this agreement.
(2) When you make any serious breach of faith regarding this agreement.

6. Limitations on Liability Roland may change the specifications of this Software or its material without
notice.

Roland shall not be liable for any damage that may caused by the use of the
Software or by exercise of the right licensed by this agreement.

7. Governing Law This agreement is governed by the laws of Japan, and the parties shall submit to
the exclusive jurisdiction of the Japanese Court.


